No 4.2 access - I have a Subscribe button

I have no access to the 4.2 version of Unreal Engine. Instead of a launch button I have a subscribe button but my subscription is valid.

The UE4 support confirmed my active subscribe status and said that I should post this issue in the Answerhub.

Does anybody have the same issues or a solution for this problem?


Sorry to hear that you are having an issue with the Launcher, and thanks for checking with our Accounts department.

  • When did this issue start occurring for you?
  • Are you a new user since version 4.2, or were you already using version 4.1?
  • If you switch the Launcher dropdown back to 4.1.1, are you still getting the Subscribe button?
  • Have you made any attempts to exit and restart the Launcher?


  1. It startet when 4.2 was released because only then I could select the 4.2 version.

  2. I use UE4 since 4.1

  3. UE4 4.1.1 works without problems.

  4. Restarting doesn’t solve the problem

I appreciate your help.

Actually, I’m having the same problem. My ‘Subscribe to Download’ problem started midway from 4.1 to 4.2. But that time logging in solves my problem. But after using the offline mode due to internet problems some time after upgrading to 4.1.1, the ‘Subscribe to Download’ issue stays even after logging my account. I didn’t bother at first because I already downloaded all the free contents, but now I think this is a problem.

I tried to test some solutions on my own, and the Install button on 4.2 now appears. Try either of this:

  • Log-in your account to, and restart your computer. Open your Launcher again.

  • Remember 4.1.1 update where you have to type in the “applabel=…”, I forgot already the entire word, for us to have access to the update? Remove it leaving only “C:\Program Files\Unreal Engine\Launcher\Engine\Binaries\Win64\UnrealEngineLauncher.exe”, then, open your Launcher.

On my end though, I restarted my computer after logging in and editing the property of the shortcut so I’m not sure which one works but I’m guessing it’s the second option since I did the first a lot of times already.

This works on me at least, since I can see the Install button for 4.2 now.

Thank you very much Ranz!

I forgot to delet the command for the 4.1.1 preview.
After I deleted it I could update.

The problem is solved!