Niagara scale issue (UE4 -26.1)

Hi guys. I’m having this issue with niagara particle system, where particle system is scaled down when parented. It works alright when not parented, but as soon as it is parented, and I press “Play” or “Simulate”, it shrinks down to like 10th of its size. Emitter is set to “local space”, it also works fine in the editor, but as soon as I press play or simulate, it just shrinks down. Has anybody experienced this before? Is there a fix for this issue?

It would not shrink without ‘local space’, of course. When you say parented, do you mean it’s a component in a BP?

It is a component in a BP, and BP is parented to another Actor in the editor. To clarify, it is a project where player can take control of spaceship, but is also able to walk through interior. To avoid issues with physics, where player, NPCs and other objects are inside moving spaceship, I’ve done it a way where spaceship itself is a static object, and environment is moving/rotationg. Said particle system BP is parented to level root actor. Also, unchecking “local space” automatically move particles to center of the level (0, 0, 0).

What is the PS supposed to be in the level?

It is space/gravitational anomaly. It is supposed to just sit there and move/rotate together with level root. Like other objects placed in the level (planet, enemy ships…etc.)

Ok, solved it (hopefully). Finally, after 2 days of messing with settings. Changing “Source Mode” from “Default” to “Default Mesh Only” in Static Mesh settings fixed this issue.

1 Like