"Newer version already installed" error when installing


I previously had Unreal 4 installed. Later on, I participated in the Fortnite Alpha, which affected my launcher and moved the engine to another location. After this I uninstalled everything Unreal4/Fortnite related. But right now I am trying to install Unreal once again, but it gives me the message “Newer version already installed” and closes the installer. I am using UnrealEngineInstaller-1.9.2-2361519. I have tried wiping any trace of the engine on my machine, including the registry, but I get the message anyways (I restarted my computer as well ofc).

I am running Windows 7 Home Premium, 64-bit.

Any ideas on how to fix this besides reinstalling Windows? Thanks in advance.

I participated in the Fortnite Alpha, which affected my launcher and moved the engine to another location

Very odd, your existing UE4 content should not have been impacted. In any case, just uninstall Epic Games Launcher.

Start->Control Panel->Programs->Uninstall a program: Uninstall Epic Games Launcher.

OR you could also just run the Fortnite alpha installer and select the ‘Remove’ option.

I somehow entirely missed the Epic Games Launcher in Uninstall programs, although it was deleted in my system and the registry cleared as well… But yeah that did the trick, I can now install.

But I’m fairly positive that the Fortnite install affected my launcher. I remember that during the install I saw my U4 desktop icon disappear. When I looked for the engine it was moved to a different directory (I’m not 100% sure about that one). Another person had all their U4 projects removed including the examples, I did not check if that was the same case for me.

Im having the same issue, after uninstalling and trying to reinstall its says I have a newer version installed. Im on windows 8.1.

Issue for me was my firewall. I tried the newer installer again and I got it working. Still not sure why it wouldn’t let me install an older version after I thought I had completely removed UE4 from my computer.