Download

Newbie in panic: Can't see the BSP

Hi there,

this is my first hour with UE (coming from Hammer Editor), and I already got stuck right at the beginning of the first tutorial: placing a box in a new level. The placing works alright, but, opposite to the picture in the tutorial, the box is displayed as a wireframe, not with rendered surfaces. So, after deselecting it, it is completely invisible. Here’s my question: How do I set the display mode of the BSPs and the level?

Thanks, newnexo

Unreal has a fantastic manual. I would check out the section on BSPs.

I haven’t even looked at UEd for years but after subtracting (I assume we still subtract?) you may need to build, add lights inside the box or even texture the box from inside but I expect you’re not using the UEd icons correctly yet in the viewport. Well worth doing what Allen said, just a simple walkthrough of subtracting BSPs will get you going.

Just to elaborate a bit, UEd always used a solid map initially that you’d carve spaces into by subtracting cubes and shapes out of it. I believe this is optional now or so I seem to remember. You can either do this by subtracting rooms and corridors then decorating with static meshes or you can initially subtract a large area the size of a zone or the map, then add polygons, smeshes, objects, terrain and a skybox to your liking.
To try out a very basic map, just subtract a box of about 2000^3 and place a few ambient lights on the ground, a few player starts, some path nodes for the AI to navigate along and a weapon locker wouldn’t hurt if it’s not too fiddly to set up (I forget if it needs any setting up first). Then you can ‘build all’ from the drop down menu and try the cube out. When it’s loaded bring down the console with ~ and type addbots 10. One other thing I can’t remember how to do is tweak this so you start this with the desired weapons, bots, gravity etc, so you’ll be trying the map with the assault rifle and shield gun. It’s most likely alterations to a config file somewhere, worth looking up how to set up starting conditions if desired.

You have to set the view mode to “lit” in the viewport:

Thx, Guronzor.

Allengingrich: Please do not post within my threads in the future.