[ New UMG Widget ] Color Picker UMG Widget, The Same Color Picker You Know and Love!

I will try to keep this repository up to date.
Right now it should work with the current editions of 4.17, 4.18, 4.19, and the promoted branch.

@calembendell Can you preview your version again? I have tried master and it didn’t work. I also tried promoted, and it still doesn’t work, but it also says 4:20, and not 4:19. Might have something to do with it…

@calembendell I tried adding this to my project and it did not work. Usual error messages “Binaries for plugin are missing or incompatible” & “plugin failed to load because module could not be found.”

Hey @RealAero and @wickerman123,

I’ll be looking into this today.
I have the color picker currently deployed in an application built using a slightly older version of the promoted branch.
Perhaps I forgot to push something to the Github repository!

Sorry for the trouble.

@RealAero @wickerman123 ,

I’m not actually sure why you’re getting errors.
I run git clone https://github.com/calben/UnrealVictoryUmgPlugin Plugins/VictoryUmg in the root of my project, regenerate the visual studio solution, recompile, and run the project without error.
Are there no errors when you attempt to compile the plugin?

Oh, silly mistake on my end. @calembendell I was using a blueprint project opposed to a C++ one. I am used to C++, and was quite surprised the project I was using this plugin on wasn’t a C++ project.

it works fine on C++ projects, thank you!

I should look into figuring out how to provide releases for each individual Unreal version for Blueprint projects!
I’ve been wanting to figure out the Github releases feature for a while now :smiley:
Glad it works!

I tried this plugin & it works perfectly on windows, but failed on android. Do I miss some steps on android build?

Any suggestions how to remove part of the widget without touching the engine source files?

Did you use UAT.bat(i follow this tutorial https://youtu.be/WtfLfYY_k2Y?t=39) to recompile the plugin? I use this method can only rebuilt plugin for UE4.17 successfully, and failed for UE4.18 or above it. Have you any idea or method shared it for me. Much aappreciate!

Not work in UE4.23
[SIZE=2]1>E:\UE4\Engine\Plugins\Runtime\VictoryUMG\Source\VictoryUMG\Private\JoyColorWheel.cpp(1): error : Expected JoyColorWheel.h to be first header included.[/SIZE]
[SIZE=2]1>e:\ue4\engine\plugins\runtime\victoryumg\source\victoryumg\public\SJoyColorPicker.h(14): fatal error C1083: Cannot open include file: ‘SColorPicker.h’: No such file or directory[/SIZE]

Same here with 4.24.2

My Solve:

Open the


\Plugins\UnrealVictoryUmgPlugin-master\Source\VictoryUMG\Private\JoyColorWheel.cpp

Add a


#pragma once

before the includes.
Switch the includes, yo JoyColorWheel is the first included.

If you now get an Error in the SJoyColorPicker.h File, it can be cause of the Include Path…
Simple Change


#include "SColorPicker.h"

to


#include "Widgets/Colors/SColorPicker.h"

This worked for me and the Editor started up.

any body can help and explain how to use ( install ) the plugin for noob in unreal :frowning:

i rebuilt this for 4.25

I’m not able to package with this version, any workaround?

By any chance can you rebuild it for Unreal 4.26?

Hi. I’m using this amazing widget, but I just found two problems.
One of them is that when I use the widget in a standalone game, the eyedropper just changes its coordinates…

(Sorry for the bad quality of the photos, but I want to show the mouse pointer actual position).

The other problem, is that when I package the game, and I want to use the eyedropper, the pointer dissapears. Thanks for any help.

Danny

Guys anybody have this Colorwheel working for 4.27 or maybe UE5? This is super urgent, calling all forces of Light to help!

Rama:
:zap: :zap: :zap: :star2: :rose: The Forces of Light have Answered! :rose: :star2: :zap: :zap: :zap:


:zap: The UE5 Version Lives!!! I’ve added this Color Wheel to My Victory Plugin for UE5!


UE5 Video

1 Like

Can this Color Picker be modified so that values of more than 1.0 can be saved for the V in the HSV?

Where can I download this for UE 4.27?

Rama mentioned in his original post that this is part of Unreal Engine now? If so, where do we find it?