New tabs in blueprint editor always open as new windows

Hello, I have a certain problem with blueprint editor and I am looking for some answers. It may really be a simple issue, but looking on the internet I couldn’t find a solution. My problem appears only in the version 4.24 and only in the blueprint editor, not in any other. When I open really anything, be it event graph or new function or construcion script, it opens in a new window, never as a new tab. It may not really be an issue for some but it takes away a lot of time from me as I need to dock every new window back where I want it. I couldn’t find any option anywhere to change that and even reinstalling ue 4.24 didn’t solve my problem. Thanks for all the help in advance!

I will also provide a screenshot to maybe illustrate my problem a bit more.

I know, really irritating, right?

Solution, editor preferences:


Thanks for responding. However, that doesn’t solve my issue. That setting was something I stumbled upon during my internet search and after fiddling with it for a couple minutes I noticed it influenced only opening new assets from asset browser. Then I looked for a similar setting in Blueprint Editor settings, but well there is none like that.

Did you try window -> load layout -> default editor layout


Yes, it also didn’t help. I even removed all layouts I had saved and then reloaded thinking it may solve it, but nothing as well. I tried different things and was searching over the internet for like 2 days now and really cannot find anything. After all I think that there may be only two possibilities, it may be just some issue with my pc, or just some very uncommon bug with 4.24 version.

I assume it’s ok with other projects.

It’s somewhere in the config, but I have no idea where.

One option, if you’re desperate, is to migrate everything…

Well sadly it is a problem in every project that I open in 4.24. But I didn’t think of looking into ini config files, I guess finding it there is my only option. Thanks for all the help!