New Project tooltips

Is normal I dont get any tooltip in the Unreal Project Browser?

Is that building from source?

If so, I’ve seen that happen when my Templates didn’t match my source. Have you downloaded the correct required packages for the branch you’re building?

No, is from the Launcher. I will try to build the source and see what happens, I will tell you.

Also I make a “verify install” and nothing changed

Makes the same thing from the source :frowning:

Watching out the code I found in:


In the 923 line of code, where says that make a Template item for every discovered project, that the things is doing to show me that screen is the code evaluates the 943 line which is the one saying “//If no template name was specified for the current culture, just use the project name”

I’m a little bit lost from there right now finding out why evaluate that as empty.

I don’t post here the code because I belive is not permited, but I think I give a clue to watch out was happening.

Hope you can find a solution and I will keeping an eye too

Looking more I found that in:


Is missing the “)” closer bracket in line 2 and 5

I found this on EU4.log :

[2014.04.27-15.28.16:435][ 0]LogInit:Warning: We appear to have no tool tip localization data? Editor can’t run.
[2014.04.27-15.28.16:435][ 0]LogInit:Warning: We appear to have no property name localization data? Editor can’t run.

No matter if I try 4.0.2 or 4.1.0 Launcher version or Code Build(with no problem on VS) is always the same screen at Unreal Project Browser

EU4.log Zip

Ah, I’m able to reproduce this by changing my editor language to something we don’t have project template translations for (I chose Japanese).

What do you have set in this menu?

As you’ve found in the code, it seems that if we don’t have a translation, we fallback to using the raw template name. That seems quite nasty behaviour, we should probably fallback to an English translation first, and use that as an absolute last resort.

OK, now it’s fixed to me, I’m going to tell you what I did.

First time I saw the problem, I check such window ( Region & Language) and I have the same that you showed to me, I didn’t change nothing (Not even a click). I thought, well I want English and I’m from Spain (Europe) but well I change the region when I start to develope something (I’m on the learning process, getting fun). So I turn my eyes on the code to see where the Unreal Project Browser is drawn and try to find what is happening. Then you post this and I said, well I’m gonna change the language and see what happen. I open a project, went to the settings and in that moment I open the drop menu Language and select English again, close the editor, turn it up again and FIXED.

So to me, is like in a fresh installation, in the process of set English as default, something went wrong, nothing is set and maybe that’s why don’t find the template name, because can’t find the localized what it had and put that raw directory name.

Hope this will help you to get rid of this nasty little bug and noone get that ugly raw TP_NAME screen again and yeah as you point out, it would be better to localized onto English always in case nothing is found.

PD: I have to re-select English ( is shown English but is like nothing is set) on the Launcher Build as well on the Code Build to be fixed, don’t know if the OS language had something dealing with this problem, mine is on Spanish.

Sorry for the long post and have a good Unreal Life.

Excellent, I’m glad you’ve got it sorted, and thanks for the extra information.

I’ve raised two bugs regarding this; one to make sure we set the editor region correctly, and one to use English as a fallback translation.

Just to let you know, both of these issues have now been fixed and will be available in 4.2.

So nice!, Is something really cool to help to point out problems (little or bigger) and seeing you get those fixed, making this wonderful program being better. Thanks for this support guys, keep going!