New Project is missing files when packing

I made a new 3rd person C++ prject and pack it and I get the following warnings:

UE4Editor-Cmd: [2016.12.10-09.01.15:425][  0]LogLinker:Warning: Can't find file '/Game/Client/ThirdPersonOverview'
UE4Editor-Cmd: [2016.12.10-09.01.15:435][  0]LogUObjectGlobals:Warning: Failed to load '/Game/Client/ThirdPersonOverview': Can't find file '/Game/Client/ThirdPersonOverview'
UE4Editor-Cmd: [2016.12.10-09.01.15:445][  0]LogLinker:Warning: Can't find file '/Game/Client/ThirdPersonOverview'
UE4Editor-Cmd: [2016.12.10-09.01.15:455][  0]LogUObjectGlobals:Warning: Failed to load '/Game/Client/ThirdPersonOverview': Can't find file '/Game/Client/ThirdPersonOverview'
UE4Editor-Cmd: [2016.12.10-09.01.15:465][  0]LogUObjectGlobals:Warning: Failed to find object 'Class /Game/Client/ThirdPersonOverview.ThirdPersonOverview_C'

I am fully aware that this is “just” a warning, but firstly I don’t like warnings (and you Epic guys apparently neither hence your standard compiler setting of “treat warnings as errors”) so hy is a brand new project missing files?

Secondly, my main project can not cook at all because the cooker “can not find: NONE” which is basically related. The problem in both cases is: How can I find out where these missing entities are referenced?

The warning thing is of course not so much a problem, but what is badly needed is a way to figure out where something is referenced when the cooker emits a warning/error. Right now, my main project is screwed because I can not cook it and I have no means of finding out where this NONE reference comes from.

If there was a way to figure that out, both problems could probably be solved


Another user has reported this over on this post and I’m currently investigating this to find out why this reference is sticking around between projects. It seems like something related to the engine installation in some way, as I got an example project from the other user but I’m not seeing the warning.

Yes I saw several of those reports and all had the user’s specific path in the error message, for example my application is named “Client”.
I also completely uninstalled and installed UE and made a new project with the same result. I thought something is stuck in an ini file in the UE directory system but if so then it is something that is not removed when uninstalling UE

As mentioned in the other post, one thing that isn’t removed when UE4 is uninstalled would be the data under C:\Users\AppData\Local\Unreal Engine. There is data stored here for each engine version. You can try deleting this but it wasn’t able to help the other user. As I’ve asked him to do on the other post after speaking to another about this, could you try running the console command I posted there and post the output you get from it?

Unfortunately, as we cannot reproduce this locally since it seems specific to your editor installation, we will not be able to proceed in investigating this issue. As it is just a warning and doesn’t impact the packaging of your project, I hope this this won’t be an issue.

Have a nice day!

Hi. This is easily reproducible, apparently, because it happens in a number of my projects. ThirdPersonOverview is a tutorial asset that we typically delete because it is extraneous. It is being referenced by the engine somewhere so the cooker says it’s missing.

I can see the asset being referenced in Templates\TP_ThirdPerson\manifest.json and Templates\TP_ThirdPersonBP\manifest.json.

Create a third person template and delete the tutorial asset. I see the warning when I build my server in the frontend, tho it seems it also happens elsewhere. It’s not that big of a deal but it looks sloppy for those of us who are releasing projects to other developers.

Hello Jin_VE,

As mentioned previously, this is an issue with the installation of an engine that is local to the computer so seeing it in all of your projects makes complete sense but does not mean that this issue is easily reproducible or we would see many more reports of this. I tried exactly what you have mentioned to reproduce this and have never seen this warning message. I also tried getting a project directly from the previous user without any success.