New project doesn't compile in Windows 7 (4.16)

I solved the problem somehow.

I have a problem with Unreal Engine 4.16 a new top down project(c++) doesn’t compile. Unreal can’t find the file ws2_32.lib.

I don’t have a idea where I should find this file. This is the complete compile text from Unreal.
When I try to start the project it sais: The following modules are missing or built in a different engine version:


would you like to rebuild them now?

When I press yes it starts building and I get the error MyProject4 could not be compiled. Try rebuild from source manually.

Thanks for any help : )

A bit more info:

I also tried to install the Windows SDK and even but it didn’t work, I installed the .NET Framework 4.7 too.
I tried the make a blueprint project, which worked, then I added code and I got this error

I have already asked the question here.

I solved the problem some how:
If you experience the sam problem read this question and Enable in VS .net-Desktopdevelopment and Gemadevelopment with c++. I hope it helps.