Download

New PC builds lighting different?

Hi guys,

I moved my project folder to a new PC and tried to rebuild lighting on a specific map and it results just way to bright. Both running UE4.25.4. I adjusted the scalability to the same values as the old PC and I didn’t change anything else. Also the exposure is the same. I rebuild the light on the old PC and it works fine. I moved the BuildData of the map from old PC to the new one and map looks fine there.

If lighting build finished it looks slightly darker than the original, afterwards I hide/unhide the map and it gets way to bright. Same happens if I restart the editor after the lighting build was finished and saved.

Did I miss a config file from inside the engine folder or wizzardry going on here? I’m quite puzzled.

Thanks a lot in advance for any answer.

It is brighter because you are layering temporary preview lighting onto the baked lighting when you re-hide the map. Perhaps it initially bakes darker now because the auto exposure is not kicking in? Did you try flying around the scene after the bake?

Hi jmancoder! Thanks for the reply! I made the exposure fixed by game values and it shouldn’t change. I noticed that it actually got only bright inside my lighting importance volume (which also covers the plane from the following pics) . Still strange why it would build light different with the same settings on different PCs. Is it fine to just move the project folder to the new PC? I built also after deleting Saved folder and all BuiltData files, but still the same result.

How it should look (imported BuiltData from old PC):

After lighting build:

After reflection build:

Is the light build quality level is the exact same on both computers?

The lighting build quality is set on both to preview. Lightmass settings are the same. Scalability is also the same.

Are there some settings which affect how the light is build inside the lightmass importance volume? Without it the plane from the picture looks fine again. Can’t remember if I might have changed some settings for the lightmass importance volume (if there are any). Already 2 years into the project ^^

You generally want to use Lightmass Importance Volumes to save on light build times so I wouldn’t recommend removing it. The volume concentrates higher quality lighting within its bounds so that could be why you’re seeing a discrepancy there.

Have you tried bumping the quality up to medium to see if there are any changes?

Check the Lightmap Resolution view, and the intensity units on your light sources. They may have reset unexpectedly.

Thanks! Sry for the late reply. Was on holidays. I’ll check those. I’ll let you know. Thanks again.

Let me ask another question that is in a different direction. Did you move from NVIDIA to Radeon by chance? or vise versa? Also check the GPU control panel for differences between computers if possible such as auto exposure, calibration, and others.

@dthompson444 It seems that it is not the computer as I tried it on the exact same model as on the one it works and there I have the issue as well. Definitley ue or config issue.

@jmancoder I checked an additional three times and both settings from lighting source are identical :frowning:

I also noticed that the shadows in distance are much harder now. DistanceField Shadows and Meshes have the same settings and are activated. DirectX settings are the same.

I really can’t get my head around this. Been trying for hours now. Any other suggestions? Might be a default setting on engine that I onced changed? Is there a way to compare that faster than going through each config line? Like GitHub revisions?

finally solved it…I removed the lighting importance volume, built light, placed a lighting importance volume again, built light again and voila, it works. Not sure if that might get into the cathegory of bugs to fix.

Hope it helps somebody else with that issue. Thanks to you guys for the support!

1 Like