Download

New material's colour is a variable in a construction script. I cannot properly initialize it.

Good day,

I’ll post two pictures. There’re PB_Block, my blueprint, and its variable BlockColo which I can’t set. As a proof, please see the picture below.

You didn’t specify the parameter name…

It does not help.

Well what did you change it to, and what is the parameter in the dynamat?

It’s Block Colour everywhere.

So your material has a parameter called ‘Block Colour’?

Have you tried changing it to not use a space?

You have to get it exactly right, I’m assuming you called the parameter BlockColor?

Yes, I changed the new variable name to BlockColor, and there is some animation being happened after I choose a new color, but it does not lead me to actually changing a color of the block.

Yeah, I tried. Nothing is changed though.

Perhaps the problem is with the material itself. Can you show us?

It’s possible dynamat is having trouble in the construction script.

Try putting it on begin play, or make an editor function which runs this instead.

hey there ! you have to assign your material to your mesh in order to work properly. overwise it will only do a material instance without using it (just add a set material node using your instance and it should do it)