New Launcher message then poof

Curious if anyone else had seen this. I was right in the middle of working on my game getting ready to burn a test copy to dvd for my son to test the first two levels. As I was getting the dvd folder ready I notice a message said that there was a newer version of what I believe it said was the launcher. Not wanting to update anything before I burned the DVD (so I could mail it off to him tonight) I clicked Not Now.
Obviously that was not good… all of my unreal disappeared, links, files etc. Game appears to still be ok under my documents so I am hoping it will not be messed up.
So instead of getting a dvd out tonight for his review I guess I am reinstalling all of the software. (just at 50% now)
I am hoping the game is ok but when I clicked on the game in the library I got a non x64 message. I am hoping that it was just because 4.9.0 was not loaded. There was no option to select x86 over x64 it just installed what it wanted from the web link.
Any thoughts on what ‘bload’ up?
It really sux because it never fails at 10:30 at night the entire dealeo took a dump. Maybe that is the Unreal part?.. ar ar… though that was not quite the words I chose at the time though. :slight_smile:
Maybe some really bad functionality on the updates? (You said not now but we say NOW! heh)
Since 4.9 is still loading, I had plenty of time to type up this post though… heh. maybe too much time.
Thx in advance.

Ok, so I am still getting a 64 bit error message so it is almost like it thinks it is an x86 version so I cannot launch my game. Dang, guess I will work on this tomorrow. Sad.

Perhaps you could upload a log for someone to look through?

Have you tried signing out and then in?
I had a problem on the first of this month of the launcher(x64) saying that the engine and my projects did not exist.
I solved that by running the x84 version and the engine and projects showed back up after signing in.


Edit: I remember reading somewhere her that you could manually launch the editor without the launcher, Mine is: “G:\Program Files\Epic Games\4.10\Engine\Binaries\Win64\UE4Editor.exe”

Well, turns out that after a couple reboots, another message about an update and a restart of the launcher it got rid of the other messages. Except now I get an error message that says that the level1 map “appears to be an asset file”. I am thinking that I have now loss all of the hours working on the levels since all three I had done are now gone. I have tried copy some files back over, not sure what the heck happened, but I had finally had the levels ready for some testing and now I think they are all trashed. Thinking I am about ready to give up on it. Hours and hours of design and coding, blueprint making and now nothing to show for it does not bode well. But I guess I do have a brand now Welcome to Unreal 4 Engine tour pop up I can look at. Will let you know what happens…( or you may not see me on the forums again. :))

So I was thunkin… There is a backup directory. I have copied all of the umaps from there back into the project maps dir. Didn’t work. I have a copy that I made to usb drive… will try that. Luckily, I had copy one of the maps and am still able to open it. Lost all of the meshes, but at least from the looks of it, I still have the blueprint work from it and that was a big one to lose.

Curious… is there multiple versions of 4.9? Maybe I had something other than 4.92? Since it deleted everything I am not sure what version of 4.9 it was built with.
The backup copy maps fail as well. yikes.

Ok, really hope this helps someone. I think I have the level problem fixed. Because Level 3 was actually working and was just a copy of Level2, what I did is I deleted all the maps in the current map directory then I went onto my usb drive backup where I had copied the directory before I started doing anything. I went into the Saved/Backup directory and found the file stamp of the Level3 file (There was only one because I had not done any work on it, it was simply a copy). I then found the Level2 and Level1 maps the closest to that time period and copied them into the current maps directory, renamed them back to Level1.umap, Level2.umap so they matched the original names.
In theory I could keep trying backup maps to the point of failure, but I have already waisted too much time getting them back. I believe the only changes were moving meshes around which I can just redo.
Cool beans, back in 'bidness.
Thanks Ryan20fun for your response, it was greatly appreciated!

One final comical note… :slight_smile: So I get the maps up, press play and my controller is not working… WTH!!! I checked the project settings and everything is as it should be. I tried the keyboard controls and they were working fine…
the controller just happened to turn off… DOH… plugged it into another usb port and woop dee doodle… ouch.

Could you report the launcher and version problems as separate bug reports to AnswerHub please? The launcher update shouldnt have affected anything else, and you should be able to open your project in 4.9.2 or even 4.10 without a problem so i dont know whats up with that.