Download

New hair rendering system - Binding to skeletal mesh causes precision issues

I’m getting precision issues when trying to bind small grooms like eyebrows and eyelashes to a skeletal mesh. Already tried to export at 10x scale and import at 0.1 to no avail since it messes up the binding. Hope this will be fixed in the future!

Is anyone else getting this issue?

Did some more testing and finally figured it out. The skinned head cannot be part of the body, but has to be a separate mesh/asset in the DCC and in UE4.

Others have the same issue:

https://forums.unrealengine.com/development-discussion/content-creation/1715238-new-hair-bind-groom-to-skeletal-mesh-frizz
https://forums.unrealengine.com/development-discussion/content-creation/1794839-bind-groom-to-skeletal-mesh-eyebrows-and-lashes

Just tried the latest master (4.27) and the issue persists. Hope it’ll be addressed in the future.

Yet another case here:
https://forums.unrealengine.com/unreal-engine/feedback-for-epic/1829180-groom-render-error

Can we please get an official response from Epic devs about this issue and how to fix it?

I have an official answer from the Epic devs. Video already on my Youtube channel and I will open it this week, I hope. Working on the subtitles. =)

Hi, everyone! You can find the answers here

Unfortunately Epic’s answer is just the workaround I’ve already posted here, (post 3). I wonder if there’s a way to force 32-bit precision. Having to always separate head&body is not a real solution.

Hey guys! I found a better workaround than splitting the body and head meshes. Here are the steps:

  1. Drop your mesh and hair into the scene, attach the hair to the mesh.
  2. In the content browser, right-click on your imported skeletal mesh -> create a new physics asset.
  3. In the Phat editor, delete all the physics bodies but the one for the head.
  4. In the skeletal mesh editor under “Physics”, assign the newly created physics asset. (If it doesn’t update, toggle between old and new. The preview icon in the content browser should focus on the head now.)
  5. Create a groom binding asset for your hair and select the skeletal mesh under target mesh.

Hair_Prec_01.gif

2 Likes