Download

New gear looks fine in PIE/ADK but does not show in Game

thewookie’s tutorial on youtube is a good start to making your own armor types https://www.youtube.com/watch?v=Ifln2SPvgRY

The issue that I found was to do with my graph code. If you wish to reference items, mainly for the purpose of seeing if a player is wearing a full set, and this includes a self class reference. Do not use “Cast To XXXXX” for this purpose, create a variable (array) of PrimalItem Class (Purple, not the light blue) and add the records you need (defaults) which would be the purple class references of your desired items. In the graph simply just get the class of an item (getClass) then use the Equal(class) and a foreach, run your array through the foreach and in the loop body compare the item class, and your arrayClasses with a branch (if equal true/false)

2016-03-09_2338.png

I’m creating new armor for my mod, and it looks fine in ADK/PIE tests but cooking and then running the actual game, wearing said armor just leaves the char looking like the default pawn (Naked, no hips/see through) now the Icons work fine, just the mesh doesn’t render in game.

I would post pictures but I’m not at my RIG so I’ll recap my actions:

  1. Copied Ghilie_Helmet static mesh
  2. Exported Ghilie_Helmet Mesh
  3. Imported Mesh into Blender
  4. Made changes and exported as FBX from Blender
  5. Reimported Mesh into ADK
  6. Repeated above 5 steps for Female Mesh of Helmet
  7. Copied PrimalItemArmor_Ghilie_Helmet
  8. Renamed Helmet and Setup Item Connector Infos to use new Mesh
  9. Copied over PrimalItemArmors: Riot Shirt. Hide Gloves, Hide Boots, and Cloth Pants
  10. Renamed above 4 items
  11. Created Custom Random Item Colors for each piece of armor
  12. removed color customization on armor and assigned my custom color objects (so it’s precolored)
  13. Adjusted Stats of all 5 items
  14. Rest of the actions, Adding Graph code to attach buff, new buff, Engrams.

I did a search and someone said if I wanted to reference something in vanilla ARK I need to just copy it over to my mod’s folder and reference the copies (meshes, textures, materials, etc) However it seems odd as I didn’t copy the Icons, and they work fine, and I did copy the Helmet mesh and linked it correctly (as in the PIE I see my changes to the mesh)

What do I do? I’d really like it to show in game, rather than create some sort of unholy naked man

EDIT: Everything I copy I rename, if I forgot to mention In my steps of renaming assets, I have renamed them all

So started to do what that thread I had found in my search, now it’s all broken. And all I did was alter the helmet materials, now the rest don’t show. The image on the left is what it looks like wearing the full suit. Right is what it managed to look like before I started messing with the MATs

issue.png

Ok so did a bit of testing, for some reason if I make a change to the primalitemarmor of the set I made, all the mesh references get cleared out. Which I’m assuming is happening during the cook process too. So now i’m following this tut https://www.youtube.com/watch?v=Ifln2SPvgRY by thewookie and I will see if it stops doing this.

Nope followed thewookie’s steps, if I close the ADK, open the ADK. Run the PIE wear the gear it works, as soon as I open the primalitemarmor object, and hit save + complie (no changes) it cleans out the meshes for all of the new armor pieces. Which is insane, I have each mesh copied and renamed and had them referenced. Is my ADK busted? It doesn’t do this with a crossbow I made.

I’m reinstalling the ADK, and if this still doesn’t work then I don’t know what to do. Anyone have any insight?

Nope, no luck, reinstalled ADK, started over from scratch. On saving one of the items allll the other primalitemarmor records just “clear out” their static mesh. Which this is just p–ing me off as once it’s cooked shows the player as a naked dude. I’m really running out of options for how to resolve this. 2016-03-05_1755.png
Is there really no one that is able to help?

Same thing happens when trying to modify pawns. It’s an incredibly glitchy system. The issue there stems from childing and such.

I suggest you copy the _BaseShirt, _BasePants, etc to your mod folder(and I would also suggest getting some further structuring going on in your mod folder, but that’s just an opinion) then reparent your BP’s to the new _Base’s in your mod folder.

Also, you don’t overtly go into detail about what exactly it is you’re modifying, especially in regards to changing the skeletal meshes, there are a lot of settings/variables in the Actor Class Attachment Info’s.

-WM

I had it structured nice, but then this stuff of the meshes dying kinda made me just try things, and didn’t bother much with proper structure (Asset Folders)

All that is in there is copied (but some still references vanilla objects, just kinda went off of thewookie’s video and a thread that I found)

As for what I modified everything is the same settings that the items I copied, only thing that would be unique would be the helmet. As I exported the mesh, removed the leaves from it (Ghilie helmet/hood) reimported it, I also created a itemcolorset as you can see on row 3 (row 1 being the top), I don’t have to copy ALL the references do I? animations and such…

I know I see people with custom armors (star wars mod, someone has fallout power armor) and looks like no issue for them. And all I’m using is recolored with different stats, and some coding to give a buff if the full set is worn. So I’m at a loss now, I’m going to copy those Base objects and reparent and see how that does. Is there anything else you need me to supply?

So I copied the base Classes, and reparented them. Same effect.
-snip link-
Here’s a video of whats going on, I tried to slow it down the best I could but Jing only allows so much time, and is apparently choppy.

EDIT:
I’m about ready to give up and just make items that can be activated to give my unique set/class buffs, but that will require more scripting just to disallow rapid switching (which could be done with the sets too, but it requires more to be worn. Idk I would have liked set pieces but it’s looking like that isn’t working for me.

EDIT2:
Like why does saving or compiling one of the set items makes them all want to be recompiled and just clear out the meshes. Makes Zero sense. Is it because the static mesh for the helmet I exported it, modified it, then reimported it?

Drop by the public Discord Server, there may be others able to help and it’s easier to communicate.

-WM

Dropped by, didn’t look like anyone had an answer at that given time. I’m going to start over again, but do one item at a time, leaving the Helmet last (as it is the one that requires a mesh export, change, reimport) problem is I’ve done all 5 pieces at once, so there is no way for me to really say “It was step X” I have a hunch it may because I have the code duplicated through each graph (so the one time fired on equip and unequip events check to see if the set is worn or not instead of using an ontick event which doesn’t really need to be run constantly)

So far reinstalling the ADK is a help (I can now drag and drop files in the kit rather than right clicking, show in explorer, copy from there, paste while in explorer to mod folder, than edit in ADK. Was a weird wrror but it’s fixed now)

reinstall didn’t solve the issue, started from scratch doing what thewookie shows, than copied the base classes and reparented (same issue)

So now resorting to doing it piece by piece, testing as I go until I hit the culprit.

Ok so I did all the other items but the helmet, and they are working fine. I also left the code on one piece of the set so far. I’m torn between an improper reimport, or copy paste code

It’s now all in and working… But the code to check if all 5 pieces are worn. I really hope it’s not as I need them to be able to check for all 5 pieces when equipped.
Does anyone know if selecting all the code from one graph, pasting into another, than recreating the variables cause issues? Or maybe the Kit doesn’t like it when you do multiple items at once.

It’s the code that was causing the issue. Apparently it’s my “cast to” references to see if equipped items are my set pieces. It somehow links them all and breaks things hard. So I fixed it by making an array of primalitem class (purple) and I simply loop through comparing the equipped item class against each array item. If true add to a counter. After all that is done, check to see if the counter is = 5, apply buff