Download

New classes not added to VS Solution

I’ve just made a fresh install of VS 2019 following those links, because I had the same problem as described bellow:

Then I’ve started to follow this one.

At step 2 I had to manually create the folder in “…/MyProjectName/Source/MyProjectName” is that a bad sign? Then VS show up with my new class, but the “Solution Explorer” is empty. I need to close VS and re-open it to get the “Solution Explorer” but

At step 3 as we can see in the CPPProgrammingQuickStart link, “.h” and “.cpp” should be added to the solution, but in my case, I can create anything I want, they are not added and not compiled even if I add them manually to the solution…

Also, i’ve added Spine to my project into “MyProjectName/Source/SpineUE4” and those files are added. I’m speechless.

Anyone had a solution? I already reached page 3 of google search with multiple keywords, it’s unbelievable.
Thank’s in advance.

I’m not sure what your issue is, but take a look at this video. Even though this is for Unreal + Sublime, the guy shows you a step-by-step tutorial on how to set up a project, and how Unreal projects are structured in general. Very well made video, highly recommend.

Unreal Engine C++ Project Setup, From Scratch | YouTube

You should have a solution already. If not you can right click the uproject and there should be an option to Generate Solution Files or something. If that’s not available I’m pretty sure you can open the project in unreal, and there’ll be an option to generate the solution under File.

Just watched the video of VS Install, I did the same thing but as described in my first post, when I try to create a new class I had to manually create the folder “…/MyProjectName/Source/MyProjectName”, also I saw a second error I have to create manually"MyProjectName.Target.cs" and “MyProjectNameEditor.Target.cs” in “…/MyProjectName/Source/”, but I still dont see those file in the “Solution Explorer” on VS.

Yeah i’m generating files for VS by doing “Generate Visual Studio Project Files” by right clicking on the .uproject file but it seem to be imcomplete (tried multiple times)

I’ve mannually added Filter, ClInclude and ClCompile into Intermediate\ProjectFiles\EndlessLight.vcxproj and created MyProjectNameEditor.Target.cs and MyProjectNameTarget.cs, a folder MyProjectName in Source and MyProjectName.h, MyProjectName.cpp, MyProjectName.Build.cs but but new files arent compiled.

I watched a lot of video and this should be automatic but not on my side, any idea ?

When I create a new C++ drom the Editor, files are created in a different folder that the described location (in the Add C++ Class windows).