New C++ project in UE, opens Xcode, build fails. CodeSignNoMatch & Required Error

Good day to all.
Hoping someone could help me out, totally new at this.

Hardware & Software:
iMac OS X Yosemite 10.9.4
Xcode 5.1.1
UE 4.4.1 (Installed using regular installer from UE website, not built from Github source code) Everything is more or less in default settings from install.

My problem goes something like this…

When creating any new default C++ project whether Basic Code or C++ Template from the UE editor, the UE Editor closes, then Xcode opens a project. But when I build the project in Xcode without doing any editing or change from whatever opens, the iOS build fails.

I get this small window that says…

No matching code signing identity found No codesigning identities (i.e. certificate and private key pairs) matching “iPhone Developer” were found. Xcode can resolve this issue by downloading a new provisioning profile from the Member Center.

I have 5 targets. I get these two errors on my iOS target.

1st Error: Code signing error.

Code Sign error: No matching codesigning identity found: No codesigning identities (i.e. certificate and private key pairs) matching “iPhone Developer” were found.
2nd Error: Dependency analysis error.

CodeSign error: code signing is required for product type ‘Application’ in SDK 'iOS 7.1’
When I changed everything in my Build Setting Code Signing to Don’t Code Sign, I still get the 2nd error above that says that code signing is required so my build still fails. Is there something wrong I am doing?

Do I need to be a registered developer? I am not yet testing any code on a real iOS device. Is it okay to delete the iOS target? Will this have a permanent effect in Xcode or the UE editor outside my project?

Does these mean that 4 targets were successful since iOS build was the one that failed?

Will registering as a developer be the quickest most painless fix for this if there are no fixes for it? and Will registering fix the error?

I also get a warning that states

Validate Project Settings Update to recommended settings Enable build active architecture only when debugging. This will enable build active architecture only for the debug configuration and improve build times by skipping unused architecture.
I clicked perform changes. I still get the warning.

Thank you to anyone and everyone who could share a fix

My guess is that you’re using the default scheme, which is [Game Name] - IOS. You need to build the Game NameEditor - Mac target, which will launch the editor. Once you’ve launched the editor, you can build the iOS version from within the editor.

I have never built the games themselves from within Xcode. I assume it’s possible, since there are schemes for doing it, but I find the best workflow so far for me is to build and run the editor and then do product builds from within Unreal’s editor.

But yes, you will need to be a registered developer to build and run on the device or to distribute your app through the App store. You should be able to use the editor and build the iOS game (testing with PIE or the mobile preview), though, without being one.

The validate project warning is no big deal. Autofix will take care of it for you, but the next time you re-generate the Xcode project from within the editor, that fix will get overwritten.

You absolutely solved my problem! :slight_smile:

Thank You Very Much!

I really appreciate it!