Download

New audio engine crashing on 4.20

Hi,

does anyone have problems packaging a game with the new Audio Engine on 4.20?
For me the compiled game crashes on launch, while some builds from another pc work fine…
I just have set the ini parameter for the new audio engine, currently no plugin like Steam Audio etc is enabled.
I found this issue Unreal Engine Issues and Bug Tracker (UE-63843) while having the problem without steam audio https://answers.unrealengine.com/que…eam-audio.html.

If I would have the same problem on all building systems I would be quite sure that the problem is somehow engine related, but a build on my win 10 pc worked while the build from another win 10 pc and win server 2016 root crashed after launch.

Would you mindy verify the version numbers in your build environments you have installed on those different win 10 machines? A couple of months back the vs2017 started acting weird crashed on editor boot at certain points. It was some trivial error in the compiler that failed to produce working binaries. Once i updated the VS and recompiled the same engine code all went away and the editor ran just fine. The same problem could apply to your game/server cooking code too i guess.

Soo, I finally had time to do some tests in the last days and it seems that the reason I get the crashes is VS.
The system that compiled a working build used the Visual Studio 2017 14.13.26128 toolchain since I never updated after I installed it, while the other machines had a recent toolchain (Visual Studio 2017 14.15.26726).
I also updated today and the compiled game stopped working with the same crashlog.
(ue 4.20.3 was also tested on one of the “broken” machines, but it did not affect my problem)
edit: I run a build on a vm now which had the same problem, but I manually forced 14.13.26128 toolset in the BuildConfiguration now
edit2: yup, the build from the vm works, so it seems that the Visual Studio 2017 14.15.26726 toolset was the problem