Download

Never had the option to compile

Hello! First time poster here.

I´m having some issues with Unreal. I´ve been developing a game with Blueprint visual scripting, and realized my game was growing in scale so i decided to start coding all new functionality, and adapting some of the existing BPs to C++.
The thing is, i don´t have the Compile button in the toolbar, and i don´t think i ever did.
I have Visual Studio with C++ for games and unreal support installed.

Any help would be appreciated, thanks!

Edit: A new C++ project does the same, no option to compile, even after adding a C++ class.

Hi!
You probably started the project as Blueprint, as soon as you add a New C++ Class the Compile button will appear in the editor.

Sadly no, upon doing that, i get a toast that says “Opening visual studio” that never fades away, even if visual Studio does open, and then i modify the class, build the VS solution, save everything and restart the editor, but nothing happens.

Create a new C++ project and check if you have the compile button. If so, that might be a bug.

OH! I actually tried on another PC, and couldnt get it to work, but now it worked with an empty one! Still have no idea on how to make the original project work from here.