Network speed drops to almost 0 when launcher is open

I have 50 Mb/s download/upload from Verizon Fios. It will be working perfectly until open the Epic Games Launcher, then the speed drops to almost 0 on everything using the internet (browser, steam download, epic downloads).
I will start a steam download and it will be ~7MB/s like it is supposed to be, I double click on the Epic Games Launcher shortcut and the download speed drops to under 128 kB/s, and I am unable to do anything related to the internet as long as the launcher is open. When I exit the launcher completely (not minimized in system tray), the download speed immediately goes back up to 7MB/s.

I have been unable to find this exact problem on the forums, but I have tried different answers that were close, but none of them helped. (-http=wininet in shortcut, disabling virus protection for testing, timeouts and retries in defaultengine.ini)

I am have attached my dxdiag and log textlink text

Are you an engine user? If you have the engine installed can you report back whether this issue also happens when the editor is open but the launcher is not?

It did not happen when the engine was open, and launcher was closed. I cannot currently confirm that again because I tried uninstalling everything and starting over. However because the same problem continued, I have been unable to download the engine.

Are you able to sign-in to the launcher? Do pages load properly if you get past the sign-in?

Also please try the following steps:

  • Shut down the Launcher

  • Open the file c:\Users[YourUsername]\AppData\Local\EpicGamesLauncher\Saved\Config\Windows\Engine.ini in Notepad or a text editor of your choice (replace [YourUserName] with your Windows user name)

  • Find the line MulticastEndpoint= and replace the 6666 with another number, i.e. 6345

  • Save the file, and restart the Launcher

I am able sign in, but the network issue stays as long as the launcher is open even past sign-in.

I edited the engine.ini file. I was able to chang the 6666 to 6345.
It is sitting at please wait

it eventually made it past the sign-in, but the network issues persist.

any ideas?

I have finally got the engine installed and now can confirm that this problem does occur when just the engine is open and the editor is closed.

I’m assuming by your last statement that ‘engine’ == editor and ‘editor’ == launcher?

I’m still guessing it has something to do with your router not liking the traffic the launcher and editor are broadcasting. If possible I would try a different router or switching to a different network to see if the problem persists. Another option is to try installing on a different computer on the same network and see if the problem reproduces.

I used another computer with launcher and editor installed. I usex the network cable from the computer that is not working and plugged it into the new computer. It had no problems

I have tried everything I can think of. and the things you have thought of. any other ideas? please