Download

.NET Framework SDK issue

Heya,

Sorry if this isnt the correct spot for this. I’m looking for some assistance. Downloaded the new Unreal Engine to play with the new features.

I get this error: An error occurred while trying to generate project files.

Running D:/Program Files/Epic Games/UE_4.24/Engine/Binaries/DotNET/UnrealBuildTool.exe -projectfiles -project=“J:/Documents/Unreal Projects/MyProject/MyProject.uproject” -game -rocket -progress
Discovering modules, targets and source code for project…
ERROR: Could not find NetFxSDK install dir; this will prevent SwarmInterface from installing. Install a version of .NET Framework SDK at 4.6.0 or higher.

I’ve tried looking for information on how to fix this. Like updating my .net framework which is at 4.8 it turns out…

Any clue?

I have the same problem, so any help would be useful.
I am using VS2019 version 16.4.0
With UE4.23 and previous versions I have no problems.

I figured it out! Okay in order to fix this you need to update via Visual Studio. :slight_smile: It now works for me.

Could you please explain better what do you need to update, and which are the steps you did?

I solved it as well.

In case someone else has the same problem, as @CupcakexBrigade3 mentioned, I installed the .NET Framework SDK (version 8 in my case) directly from the Visual Studio Installer. I’ve never done it for previous version of the engine, but 4.24 requires it.

Visual Studio Installer - Modify - Individual components - search “SDK” - select latest version of .NET Framework X.X SDK - Modify

3 Likes

Thanks! Worked perfectly.