Download

.NET 4.5 reference assembies not found - making Installed Build UE5 from source with VS2022

Hello. I’m trying to build UE5 Installed Build from source using VS2022. I built it successfully by opening solution in VS2022 and building, but I wanted to make the Installed Build, as I understand that is the way to make reasonably sized package. (Is there another way to clean the 200+ GB build - leaving only editor+engine that can be copied to other machines after building it from VS solution?)

I tried building it using:

RunUAT.bat BuildGraph -target="Make Installed Build Win64" -script=Engine/Build/InstalledEngineBuild.xml -set:HostPlatformOnly=true -set:WithDDC=false

All goes well, until after 3 hours of compiling I get:

error MSB3644: The reference assemblies for .NETFramework,Version=v4.5 were not found.
when compiling Engine\Saved\CsTools\Engine\Source\Programs\UnrealSwarm\SwarmCoordinator\SwarmCoordinator.csproj.

As I said, I have VS2022 installed and it comes with .NET 4.8 I think. I tried installing various .NET developer packs from Microsoft, but it changes nothing.

Any ideas how to fix this? Feels like wrong configuration is generated somewhere, as when building directly from VS2022 solution, everything is fine.

Thanks!

I managed to solve this myself - I just edited all .csproj files and replaced framework version from v4.5 to v4.8 and it compiled without any issues!

Other than that - it would be nice to have documentation on how to clean the build after building to get reasonable build size. Even the Installed Build turned out to be 70 GB.

2 Likes