Nested widgets don't update (bug?)

I think this is a bug, can someone with more expertise confirm:

Let’s say we make widgets A and B. The within widget A we add a User Created widget B. If widget B is edited in any way, the nested widget B within A does not update. So every time widget B is updated it needs to be deleted from widget A and added again so the updates are visible.

Edit: It looks like it happens in some cases but not others…

Any edit of a user widget once you have a copy of it viewed in some screen/window/widget, will generally not update in the editor without restarting the editor.
This has been the case for some time, and there are several forum threads about it, yet … not yet fixed.
(Haven’t tried it in 5.0 – would be interesting to see if it’s fixed there?)

Thanks for the reply. I think this goes a step further. I tested it a few times and happens sometimes and not others. To clarify:

It’s not the view in the editor that’s a problem for me but the actual behaviour and presentation on execution. For example, the nested widget could have the blueprint changed, buttons added, parameters changed or anything else, but when playing/executing these changes are not seen. The nested widget still behaves with the logic it had when it was added to the parent widget (in blueprint, not at runtime).

Is this the same error? Maybe I misunderstood.

That sounds very similar. There’s something where the widget just “sticks” in the old version where it’s seen before – this includes “play in editor.”


It’s still an issue as of UE5.0.3
Restarting the editor refreshed it and now it works.

You could just remove the child from the parent widget and add it again then hit compile and it will update without restarting the engine.

In the example below, I made a change in a button inside the “WB_FindServers”, then I remove the “WB_FindServers” which is my child widget and add it again in the same place and hit compile.
Captura de ecrã 2023-11-07 110611