Download

Needing some help to tune a vehicle suspension.

hi! I"ve made a custom vehicle for a test project and the suspension is too stiff, no matter what setting I put inside my “vehicleWheel” blueprint.

as you can see in the video, the suspension is not raising or lowering at all while accelerating or braking, and the car do not lean while turning.

could someone explain to me how the variables “Suspension Damping Ratio” and “suspension Natural Frenquency” affect the suspension?

Also am I gonna need to play with the center of mass from my car mesh? is the height of it compared to the wheel gonna make a big difference?

here is a video of a good suspension:

and here is mine:

PS: the camera is absolutely not smooth too, I am using the camera lag option on the spring arm and it skip. make me feel sick to watch it and it is worse without Vsync.

Thanks for reading.

hi everyone. As you may know, the camera lag problem was solved in update 4.11.2

I still would really apreciate it if anyone could tell me what I might be doing wrong with the suspension.

thanks for watching!

Go to “Vehicle wheel” and set “Suspension force offset” to -20 :slight_smile:

OMG Blue man, That actually worked! I dont know why it worked, but it did! thank you so much :slight_smile:

I am glad I was able to help you :slight_smile:

:slight_smile: thanks again Blue.

You can also try to set it to -40, it may look even better :slight_smile:

yeah, I like it more subtle, Im pretty sure that -40 would make it very exagerated :stuck_out_tongue: now the cockpit view is really nice, you can feel the acceleration and braking more :stuck_out_tongue:

Yeah, it looks very nice, good work.

the physic is still very bad, it feel like im throwing a toy car made of plastic on the ground when I go fast and crash onto something, I’ve seen you posted in a thread about this, its kinda sad that it is not improving at all.