Download

Need to add Reverb to a specific sound cue, but doesn't appear to be possible?

As the subject says, I have a specific sound cue that fires with a lot of different nodes randomized and concatenated together. The only problem is that I need a reverb effect to be played specifically on this sound cue. But I cannot seem to add reverb to this, and the only things I can see that deal with reverb are audio volumes. This doesn’t work since this cue is not spawned at any specific location, and nothing else should be reverbed. Am I missing something here?

Thanks!

These 3 links discuss reverb in the UE Audio System.
https://docs.unrealengine.com/latest/INT/Engine/Audio/Overview/index.html
https://answers.unrealengine.com/questions/301112/adding-reverb.html
https://docs.unrealengine.com/latest/INT/BlueprintAPI/Audio/ActivateReverbEffect/index.html

Already been through all of those. Those are too global and add reverb to everything. This needs to be specifically on this sound cue. I can’t add the reverb to the individual wav files that are being used in the sound cue because it’s essentially a random phrase generator and the reverb delay at the end of each of the audio files where the reverb fades out would make for an awkward delay between the all the parts of the phrase as a whole.

Are you using an audio volume? What if you put the sound you want reverb applied to inside of a separate audio volume, and apply the reverb only to that volume? The second link talks about audio volumes and has a link to the documentation.

No, since the sound isn’t coming specifically ‘from’ anywhere (Spawn Sound 2D), and therefore doesn’t have a location, a volume didn’t seem to be a viable option. I’m able to kinda rig what I need to do by creating two sound classes: a “default” sound class and my “hunter” sound class. I’m activating the Reverb effect just before playing my hunter sound, which has the “hunter” sound class with the reverb check applied. I’ve gone through and set all of my other sound cues to use my “default” sound class which does NOT have the reverb check applied. A very hacked and sucky way to go about this, but for this project it’ll have to do. I even tried changing my project settings to use my “default” sound class instead of the “Master” sound class, but that didn’t change anything until I specifically changed all my other sound cues to use the “default” one that I made.

I’ve been searching to see if there was a way to change the “Master” sound class itself to disable reverb, but have not found anything on that. Too bad because that would have saved me a ton of work for this.

What if you place an audio volume inside your character blueprint as a child of your character so that it always moves along with the player and the sound location would not change? Use it as your reverb volume.

I had thought about doing this. And using the spawn sound attached. But I think switching to the different sound classes may actually end up working in my favor down the line.