Download

Need to access this variable can someone tell me where to do that at?

4d90126fe4ea36d52b3f4c76db3003c741453ed1.jpeg

No matter where I put this I get variable out of scope… I’ve even pulled it from the inventory of an item and tried to edit from there still get variable out of scope when debugging… can someone please tell me where do you have access to this variable?

Is this for a weapon/item or structure or something?

If so, try the PrimalItem graph, if that image is not already from that. Not entirely sure how you’d call it. Event Begin Play could work on that I suppose… wouldn’t quote me on that though.

-WM

the issue I have is no matter where I’ve tried it so far the debugger says the “set” is out of scope. I’ve tried it as a container looking at the blueprint I just created in the container, I’ve tried on the blueprint of the item being changed though can’t figure out how to get anything to fire there because I can’t seem to find a way to fire anything … blueprint on use doesn’t seem to work either and I tried to make a function public so I could call it from outside the blueprint and that didn’t work … I’ve tried it in weapons, resources, and in the smithy shop graph … all say “out of scope”

Still having this issue

From everything that’s been learned, it is believed to not be possible to modify that kind of information at run-time or in-game, it’s the same with a couple other types as well - I can’t remember what they were specifically.

-WM

The new cooking system does it… creates blueprints with the requirements needed on the fly and uses an icon from the ui to do it… that’s all I’m wanting to do. Take the blueprint for an item like metal pick and add it to a shop with crafting requirements of 1 gold pearl. But I can’t find the code they used anywhere on the cooking pot