Download

Need help with UE4 settings, meshes don't show they are selected!

As the title suggests, my issue is that when I’m placing and using meshes (mostly static meshes at the moment) they don’t highlight to show they are selected. The yellow selector aura/brush that shows up when creating geometry would normally show up around a static mesh, sort of highlighting it. My issue is that has stopped showing up, which is making it very hard when trying to place things, especially glass! Does anyone have any ideas as to what I can do to fix this? I tried resetting all settings to default, but that didn’t seem to do anything.

A quick note on the glass: Transparent materials are not selectable by default. You have to enable that - i think it’s in the quick settings.

On the selection: Does the highlighting fail to work in the perspective and the orthographic views or just one or the other?

I’ve had a similar (strange) issue that BSP brushes that I have hidden still appeared in the perspective view (but not in the ortho views) but weren’t selectable. Perhaps that’s somehow related…

Cheers,
Michael

When you say you reset all settings, does that include the viewport ones?

To totally reset all settings, delete the Saved folder within the project you are using, then start the editor.