Download

Need Help with my custom character please!

I followed this, https://docs.unrealengine.com/latest/INT/Engine/Animation/CharacterSetupOverview/index.html#workflowataglance and i still dont have my character spawning??? please help i have is animations and blendspace1D and everything set up right i might have something wrong in my BP’s i need help please anyone…

-do you also have a character bp?
-have you assigned the right gamemode to your level?
-have you added the right character bp to your gamemode?
-how does your character bp looks like? :slight_smile:

ill record a video and show you what i have that you have listed ok and thank you for helping friend.

https://www.youtube.com/watch?v=4mMVgFHKgx8https://youtube.com/watch?v=1uGewGuVhU8https://www.youtube.com/watch?v=VxxhbRwZTGchttps://youtube.com/watch?v=BtWk5p91FH8http://youtu.be/xE4l9JmICPo
here you go

i can even get on skype later and screen share if need be

Well, in that first video it doesn’t look like you connected the Is Valid node to the Set Speed node, which is rather important. And in your character blueprint I noticed that your mesh stood in A-pose in its capsule, suggesting you might not have assigned your animation blueprint to your character blueprint. That’s all I’m seeing right now.

Is Valid node to the Set Speed node i did that but still nothing

ok i got him in game now, now he just does his idle animation while he’s supposed to walk or run he moves but does idle motion for it ??? help

https://youtu.be/3XaqatBe3fg

https://youtu.be/3XaqatBe3fg

https://www.youtube.com/watch?v=UELtSXbi6AQ&feature=youtu.be

https://youtu.be/SNBK8TjTjvc

This is were iam stuck at now anyone please help me https://youtu.be/iuJe1RJdUog

It looks like your run animation has a moving root. Try flipping on “Root Motion” in the animation. You might need to go into your anim graph and, under “edit defaults,” change Root Motion from Montages Only to Root Motion from Everything.

Either that or go to your skeleton and mess around with the retargeting translation:

ue4_retarget_translation.png

Hit “Show Advanced Options” and try changing the translations for your bones, starting with the root bone.

In addition, I should stress that a lot of tutorials cover this sort of stuff. If you haven’t checked out UE4’s official videos, I recommend you do.