Download

Need help with Landscape. Getting black material and can't sculpt.

I’m following the MetalGamesStudios Landscape tutorial (http://www.youtube.com/watch?v=FHVuVVHlUmM&list=PLyfbinWLdAUwiStRx7Zil-O0OLzpIBB9l). However, Landscape editing is not working for me. The generated landscape is all black as opposed to the grass texture like in the tutorial. In Sculpt mode, I see the circle brush when my mouse hovers over the terrain but when I left mouse click, it is not sculpted. Instead, the camera is being moved like in Place mode. I’ve viewed the scene in wireframe and can see the terrain but I can’t figure out how to sculpt it.

Here are my steps:

  1. Create a new blank project with starter content included. I left the default assets (chair, table, lighting, etc) in the scene.
  2. Create the grass and dirt landscape material as shown in the video.
  3. Go to Landscape mode.
  4. Select my landscape material for the new landscape.
  5. Click Create.

My two problems are:

  1. There is an issue with my landscape material.
  2. I can’t sculpt the terrain by LMB clicking.

Any suggestions or tips? Thanks.

Sorry, I forgot to mention in the tutorial that you have to press Ctrl+LMB to edit the terrain :o

Thanks, that fixed that part. Now I just have to figure out the black material problem.

Could you probably post a screenshot of your material and the problem?

Not sure but I think I solved my material problem or at least I can work around it. I noticed that after terrain generation, under Landscape Paint -> Target Layers, grass and dirt both had Layer info set to None, whereas in the video, the grass had grass_LayerInfo and dirt had None.

I clicked on the Create Layer Info button, selected Weight Blended Layer, and choose Minimal_Default_Sharedassets (which was my only option). I don’t know if that’s why my landscape didn’t start all green like the tutorial. I am able to Ctrl+LMB to paint and that adds the grass material.

Landscape material:

Paint settings after generation:

You have to watch my video carefully ^^ : http://www.youtube.com/watch?v=FHVuVVHlUmM 8:45 You have to click onto the little + then you have created a layer -> now everything should work

Yes I saw that and did just that. I was saying that my grass did not start with a layer (set to None) where as it looks like yours did (already set to grass_LayerInfo). After generation, your landscape was automatically filled with the grass texture. Mine was not.

Oh, you mean that ^^ Thats because I have already painted onto it, so that you guys can see the difference between those two hills (you couldn’t see much because of the black colour)