Download

Need help with join session (steam) - weird bug

Have hit a wall for the past few days with my game. I have a dev build that i have set up with the steam plug-in and am having issues when trying to connect to a lobby.

I launch 1 client, navigate to find a session and click search, No sessions found, as intended. I then launch a second client on a lap top with a different steam account and leave it at the main menu. Now when I look for a session it is finding something and failing to join. If I host a lobby (create session followed by an open level with a listen option) on either client, I get a nettraveltoclient error when trying to connect with the other. When I tested on lan everything was working as intended.

Any help would be amazing!

Silly question, but:
did you open ports, or check what ports need to be opened?

I was originally following the unreal multiplayer set-up and i believe he said that the default ports should be fine so i never changed anything. In my unreal folder the BaseEngine.ini has this in it

Protocol=unreal
Name=Player
SaveExt=usa
Port=7777
But looking through my project config .ini files I saw nothing about ports

Try using these settings: SteamCore & Finding and Creating Multiplayer Games - eelDev

That worked! I updated the defaultEngine.ini with the settings you linked. Thank you both so much for responding and helping me out!

Hi thanks for that tips, worked for me. I have another weird question, setup for steam may causes can’t connect with LAN anymore? Week ago started practicing in multiplayer in LAN, was working perfect remotely through Radmin VPN. Now add chores in the ini file for steam, and get steam remotely connected (under standalone mode of course). But now don’t get connect in LAN way

[2020.04.17-22.02.37:687][834]LogLoad: Took 0.105407 seconds to LoadMap(/Game/VirtualRealityBP/Maps/UEDPIE_0_TestMap)
[2020.04.17-22.02.37:687][834]LogNet: Warning: Travel Failure: [LoadMapFailure]: Failed to load package ‘/Game//Maps/UEDPIE_0_TestMap’
[2020.04.17-22.02.37:687][834]LogNet: Warning: TravelFailure: LoadMapFailure, Reason for Failure: ‘Failed to load package ‘/Game//Maps/UEDPIE_0_TestMap’’. Shutting down PIE.
[2020.04.17-22.02.37:687][834]PIE: Warning: TravelFailure: LoadMapFailure, Reason for Failure: ‘Failed to load package ‘/Game//Maps/UEDPIE_0_TestMap’’. Shutting down PIE.

All files are identical (synced) in both sides (Perforce). Can’t get the solution, any help?