Download

Need help with import 3ds max model to unreal

Hi all,

I am trying to import a bit complex architecture model into Unreal.
I watched many tutorials and tried to follow with some script to export 3ds max file to fbx file. (such as ts tool, uvw unwrap…)

I could import objects with materials into Unreal but issue is some objects are moved in other direction after I imported in Unreal.
I tried with UE4 FBX Exporter script and also full scene importer from Unreal. Both ways didn’t work. (Image 1. 3ds max file, Image 2. After imported in Unreal)
I assumed I might need to move objects into origin (0,0,0) in 3ds max before export. I tried to move objects to the origin then another displacement happened… (Image 3)

If anyone can give me a advise about this issue, I would very appreciate.

Thanks!
a0acb0b9811deca7a58402b422a85ea87fcabba5.jpeg b97f0ae58cf42ccf838f72b9a920836a557b1d29.jpeg Capture3.JPG

I am newbie as well with learning Unreal, so take my advice for what its worth. What I have used and is very helpful is Tom Shannon TS tool script to export my models. I use a small script, UVW AutoUnwrap from Chris Jennings to unwrap my meshes. I do not import the materials from my scenes since I use Vray. I do however important my maps.

As for importing your mesh in the correct position. Again using TStools if you uncheck “import object 0,0,0” and once in unreal drag your meshes into your level and then zero out the tranforms to 0,0,0 should work like a charm.

Below are the links to the scripts. Good luck

http://www.chrisjennings.co.uk/misc-scripts/

Try resetting XForm in 3ds max before you export, be careful though as this sometimes flips the mesh normals for some reason, you will have to reverse the messed up normals manually

Right–you probably need to Reset XForm

The reason it flips the normals sometimes is if you used Mirror to flip an object, it actually has the normals “technically” flipped after that which becomes applied when you reset the xform

Interesting, I didnt know that, I assumed it was a bug in 3ds Max. I dont understand how Mirror’ing something would flip the normals? Is it because it is kind of scaling something by -1, the way it is programmed?

I think internally it is simply changing the scale by -100%, though it doesn’t show it.