Download

[Need help] Textures changing to grey squares after dragging them(not turning back)

i downloaded this unreal 4 vegetation pack, but once i imported a mesh, i tried applying a material but the material just goes to grey squares and doesnt turn back… Pretty much tried everything, so, in a nutshell; my textures are broken. Please help!

How have you imported the package? / do you use it in your own project or as a separate one?

Normally such kind of things happens when your folder structure is not the same as the one from the original project -> you always have to make sure to keep the original folder structure, otherwise you will lose some references :slight_smile:

ive copy and pasted it into the content folder. Its taking me too long so ill probably opt for your free foilage starter kit. my game’s nothing more then a personal project.

Open the material you’re trying to apply to the mesh and check for errors at the bottom of the window. Generally a material will stay that grey checkerboard pattern if there’s an error preventing it from compiling.

In future, don’t drop things into the content folder using Explorer. Import standard files by dropping them directly into UE4’s content browser. This doesn’t work for files that are already conveyed and part of an existing project; instead, open the project they’re in, select what you want, right click and select “Migrate” and pick your project’s content folder. This process will move the assets without issue and will ensure all you need to correctly use a given mesh / material / etc. is correctly moved across.