Download

Need help on mapping

Hi,
After several weeks now trying to get sublevels working…im out of options. .
Followed bricks tutorials now i use uzumi his tutorials.
Ive made a new map now, added a sublevel called landscape, but cant move it.
Biggest problem is when you put foilage organisatie meshes on the map…
When going back to another sublevel to work on, the things i placed no longer are in the same place where they supposed to be. …
So Ive created a New map, with some sublevels in it…is there someone Who Will take a look at it pls and tell me why it is broken. …
After 2 weeks of trying, i hope someone can help, so i can finally start…
Grtz

here is the 7th testmap following uzumis instuctions…
pls if someone could find the eroor, it must be something small, dont know…filesize=14mb , only persistent + 3 submaps (landscape, far and near)
included in far and near foilage
try to place something and see what happens, you can go look for ure foilage lol
also everytime i change submap, i spanw somewhere else

PLS PLS PLS PLS PLS PLS PLS HEEEELP being at it for some time now…
or if someone can make a working persistent with some submaps in it…
if i can get it to work and post my map online (sometime in the future) ull get full credits
just want to get started finally on a map…

as it should be:

and here is when you add extra foilage(included in far and near submaps)


I think in world settings you need to click the little down arrow under ‘kil z’ and then uncheck world->‘enable world origin rebasing’. at least, thats what i have seen them say in the forums when people have foliage moving around.

Also, you need world->‘enable world composition’ checked, which is not checked in your screen shots, so I’m not sure how you have sub maps working in the first place…

yeah thx, alrdy found it
2 options need to be ticked off (world origin and boundries)

but next problem is there now…
everything looks glossy, like metal
and when i cook and upload, i spawn in the water, like there is no landscape…

when you cook, do you need to put the names of ure submaps also inthere?

grtz

no, you only need the name of your main map listed, but your submaps can’t be in subfolders, they have to be in the same folder as your main map.

dont get that middle phrase…submaps are not in folders, there all in the same folder as the persistent.
gonna try again…

failed again, still spawning in water like there is no island :frowning:

succeeded :slight_smile:
i set the landscape on “block all” insted of ground or groundterrain…
now hoping my layers stay where they supposed to be :slight_smile:

on the test map it worked, on the main it doesnt???
landscape far above me ingame…

It should be set to “Ground” not GroundTerrain or blockall

i know, thats what all tutorials say, but if i do, i fall through…
now other big thing came up…
ive made the testmap (where i spawn on landscape) my main map, so i putted all custom stuff inthere and tweaked the materials etc…
then i placed them (not much) and cooked it…took forever and only 540 warnings, before +2000

steam says 236mb but when i subscribe and it starts downloading, after download it installs, but then it goes back to downloading, installing, downloading, installing…???
when i hit play on ark, i spawn on my map, but previous version, so nothing is installed…
any help on this??
almost got a working map, almost…need some more help :slight_smile:


bumping for the bump

Mate we simply don’t know or we would have told you the answer. I suggest you start over and redo every single thing and not take any shortcuts as to find the fault, without knowing what uve done or how ur map is setup there is little we can do

Ive followed ure tutorial and bricks tutorial, step by step…cant find what im doing wrong…
Ive made +10 maps now, everytime the same…no errors, but not playable…
and here is the main map…link dropbox for all files
included the new trees and stuff…
destructable meshes and settings for harvest
.
thx in advance for helping

anyone found the bug yet?
rlly want to start mapping…

I’ve been trying to make a map too. I’ve had even less success than you (you seem to know more than me).

I downloaded your map and had a look. I put it into it’s own folder named “Tagoria”.

I had to re-link the OceanPlane static mesh to the Water Plane. I then loaded the landscape level and changed the Collision Presets to “Ground”.

I re-loaded the Tagoria level and it worked fine for me. That doesn’t help you though, lol.

Have you verified your Dev Kit files through the launcher lately? I don’t know what to suggest other than that. :frowning:

did a full reinstall of the dev kit today…
did you see the custom trees aswell?

No, no trees appear at all.

Also, the day/night system isn’t working. I’m in the same boat there.

Quick question where are your spawn points and or do you right click “play from here” because the play from here will often spawn you in the ground and I recommend placing your spawns a bit higher then you think they need to be. hope that helps, also seams like you shouldn’t get the dev kit throw steam.

there a bit higher from the ground :slight_smile:
tried something else now:
i tried to verify my mod files through steam…it kept downloading/installing that mod, no matter what i did
can cook and play, then alter stuff and play again :slight_smile:
finally :slight_smile:

1 mayor problem i have now:
sometimes my screen goes black/green/blue depending where i look…any ideas??
im using the UE4 devkit, not the steam one

and underwater and dont have that problem, i ca 360 look around, only above water its bad