Download

[Need Help]How to quickly replace DinosDeath Harvest Resource?

I’m trying to create a custom meat and replace raw meat and prime meat
Tried to remap resources from primal prime meat (PrimalItemConsumable_RawPrimeMeat) to my child custom prime (AR_PrimalItemConsumable_RawPrimeMeat_Child) but it doesnt seem to work (I test it by dropping a character_bp_rex and kill it to try to harvest the meat → primal prime still drop and not the new one)

Anyone have any idea about this? I really dont want to go through all the trouble to :

Replace meat in each of the dinodeathharvest (actually i did it already - and also map it to remap resources as well → not working)
Create everyone single of the dinos and map the new dinodeathharvest to it (this part will take forever)
map the new dinos to spawn entry (again, take forever)

Thanks,

Ps: Side question (the above one is still most important right now) - anyone know how to modify the light range of torch, campfire, light source in general?
and also, is there a way to modify the character inventory inside the testing environment in UE4 - not the actual game, just the “test play”?

I do not believe that there is an easier way to that.

Hey Nguyen,

I’m exhausted right now and my brain is tired from a day full of troubleshooting for my own mod and helping others. I’m having trouble figuring this one out currently (most likely due to me being exhausted), and will need to get back to you on it tomorrow after I get some Z’s. Sorry I can’t be of help right now, but just know I’ll give this my attention tomorrow :slight_smile:

-Sinari

No worry :slight_smile: i dont plan to release my mod soon anyway :slight_smile:

I had ran a small test with raw meat drops on tiny dinos (dodo, dilo, dimorph). I made the custom meat, made the custom dinodeath harvesting component, and each dino character BP. This was the only way I could get it to work. I didn’t have to make custom spawns. When you remap the dino character under remap npc, it automatically updates the spawns. The light source for torches and the like are in the structure BP under components. For the torch you can edit lightpoint1 and lightpoint2. Haven’t messed with the campfire or anything, but I assume it is similar.

BWic beat me to it! I was gonna try out that myself today, but looks like he already did :slight_smile:

That should answer your question

Yup got it :slight_smile: thanks guy
Here is the mod that i’m working on (not really plan to install it on my server until server mismatch version with mod is allow to run - dont want to disrupt my member gameplay with dev kit delay)
http://steamcommunity.com/sharedfiles/filedetails/?id=491022577

Hmm actually it’s still not working for me
Upload the mod and run it on local (even try to create new map for the new dinos to respawn already) the new meat is still not out yet

just use the remap item is what i used on my mod

I did all those following already

Remap new prime to old prime (Remap Item and Remap Resource)
Remap new dinodeath to new characterBP (individual characterBP and also added to Resource Remap)
Remap new characterBP to old characterBP (remap NPC)

Kinda found my problem but dont know how to fix it :confused: the mod doesnt seem to load in single player
How do i check if my mod cooked properly? it said Job Successful so I assume it’s fine (same as upload)
I check the mod folder on my single already and all the file seems to be there as well :confused:
Mod is listed under Active Mod in Single player too (the screen where you select your mod)
But when i get in game, nothing changes (checked engram list - where i have some of the stuff rename - worked in test play screen)

In my mod torchboost I duplicated (because it cannot be a child) the particle systems and modified their parameters. For light radius you would be interested in the module named Light and you just change the value for Radius Scale > Distribution. You then must child the emitter bp, change its template to your new particle system, then duplicate (not child) the fuel burning structure to change its activated emitter in components.

Nvm, it work now :slight_smile: i dont know which one of those fix it but just leave it here for those who got the problem single player dont recognize the mod:

Was using Child of GameData and GameMode, recreate using Copy instead
Was using Test Map, recreate level using the one in GenericMod (empty)

An update to my post about my test. I started a new mod last night to test the remap features. I simply remapped a child of primalitemcosumable_rawmeat and dinos dropped the modified meat. I tested wood structures by dropping the amount of wood required and it worked by simply remapping the primalitem bp as well and the engrams of course. I did take it further and test other items that interact with those modified items and they all seem to work fine as well. So it seems there now is a way to simply remap the items dropped by dinos. PS. The meat and i’m guessing all cosumables need to be remapped under items, not resources.

So i dont need to even map the harvest death table anymore? just the resources raw meat will be fine?

And just one side question, if people on my server are using the modified structure and i remove the mod, will the structure remain or all will be destroy ?
Same question for modified Dino Character BP, will the dinos remain on the server if i took the mod out? or they will disappear right away?

I also another bug where some of the structure texture become transparent on singleplayer - will this be the case with multi as well? (the modified compost bin show up fine when i first build it but become no-texture - the object still there, just transparent - when i relog)

My assumption on the first question is yes. The server question, I honestly have no idea what will happen. I could only speculate that since the structures would be saved in the save file that they would still exist but interactions with them may not work properly since they would not reference anything. Once again, not sure about that. The last question, I’ve had that problem with vanilla items several times on SP. It may have something to do with the graphics or just everything not loading initially. I was often able to leave the area, rather far from the area, and come back and they would reappear. Never fully investigated that since it wasn’t game breaking. Hopefully, someone can give more insight into your last two questions.

Hi, i come across this problem while modifying the Light Radius. Do you know how to fix it ?