Download

nDisplay postprocess section is error

When I assign postprocess section in the cfg file and run in nDisplay luncher, The error raise.

The obj file assigned in postprocess section, that is the default plane, it is exported from ue4.

Can anyone give me suggestion to solve these problems or give me a good example?

The error:
Snipaste_20200313_121950.png

The cfg file:


[info] version="23"

[cluster_node] id="node_left" addr="127.0.0.1" window="win_left" master="true" sound="true"

[window] id="win_left" viewports="vp_left" fullscreen="false" WinX="0" WinY="0" ResX="960" ResY="600" postprocess="pp_1"
[postprocess] id="pp_1" type="OutputRemap" file="plane_ue.obj"

[viewport] id="vp_left" x="0" y="0" width="960" height="600" projection="proj_left"

[projection] id="proj_left" type="simple" rot="P=0,Y=0,R=0" screen="scr_left"

[screen] id="scr_left" loc="X=0.2,Y=0,Z=0" rot="P=0,Y=0,R=0" size="X=0.5,Y=0.3"

[camera] id="camera_static" loc="X=0,Y=0,Z=0" eye_swap="false" eye_dist="0.064" force_offset="0"
[general] swap_sync_policy="1"
[network] cln_conn_tries_amount="10" cln_conn_retry_delay="1000" game_start_timeout="30000" barrier_wait_timeout="5000"
[custom] SampleArg1="SampleVal1" SampleArg2="SampleVal2"

The logs:

nDisplay dev here, could you please upload your obj file?

Thank you so much!

I stumbled across this thread when I ran into the same error.

For me, the issue was that the obj file did not specify W for the texture co-ordinates (U and V only); and Unreal/nDisplay is expecting to see all three coordinates. (see source UnrealEngine/Engine/Plugins/Runtime/nDisplay/Source/OutputRemap/Private/OutputRemapMesh.cpp / FOutputRemapMesh::FMeshData::ExtractUV)

Hopefully this will save anyone else that ends up here!