nDisplay dual monitor question

I’m trying to get a setup with one machine and two monitors (one monitor and one projector) to work using nDisplay for the first time but I’m getting stuck at the very first step.

When I launch the nDisplay example project that comes with Unreal Engine with the nDisplay Config called “NDC_DualMonitor” as-is via Switchboard, it launches on the wrong screens.
I followed these steps with NDC_DualMonitor instead of NDC_Basic, which I also replaced in the example scene.

For testing I’m just using my laptop with a second monitor connected via display port. My laptop is the (main) left screen and the second monitor is the right screen in my desktop setup in Windows 10. But it seems nDisplay is getting that configuration wrong somehow?

What is the left screen in NDC_DualMonitor shows up on my (second) right screen and what is the right screen in NDC_DualMonitor doesn’t show up at all. My main screen is just showing my windows desktop.

Where do I define which screen is which for nDisplay? I know this is a very basic question but I can’t seem to figure it out from the documentation.

Or if you could point me to some kind of basic tutorial on the topic I would be very grateful. All I could find was this and it seems a bit out of date and it was very hard for me to follow. :sweat_smile:

I have this issue as well. Did you find a solution?

Of course it’s possible to reorganize your screen in windows but that’s not ideal.

In TouchDesigner you simply select on which monitor your output window should open, other than that, it works the same, from left to right.

Did you check your EDID settings within Nvidia control panel (outside of UE)?

You don’t select which display monitor you output to perse. You setup your monitor arrangement in windows or nvidea control panel. You then setup the comfile by sizing and arranging viewport to match the layout of your windows config. Use the window position to set the position the node renders at with 0 0 for top left corner.

If you have set this up correctly perhaps try setting the window position of the node negative the pixel distance of your main monitor.

Warning: The display positions seem to get adjusted by the Windows 10 font scaling. I’m not sure if there’s a way to prevent that, (I was able to set them all to 100%).