nDisplay and Multi User Editing - not connecting to server

Hey guys!

We’ve got a working nDisplay setup, running on multiple computers. I’d now like to add another workstation running the editor and have them all connect with multi user editing so I can interact with the nDisplay scene via the editor. Is this possible at all?

  • I’ve got a multi user server running on ‘Workstation01’, the session is called ‘Test’
  • the project is configured to auto-connect to multi user server ‘Workstation01’, session ‘Test’
  • opening the project in the editor on ‘Workstation02’, it auto-connects to the multi user server (for some reason it only works using the computer name, not when using the IP address)
  • running the same project via nDisplay launcher on ‘Workstation02’, the projects fires up and starts rendering the nDisplay OK. A message pops up “Joining Session ‘Test’ on ‘Workstation01’… Looking for Server ‘Workstation01’”. But it never connects.
  • we’re using 4.25.1 on all computers
  • all computers are in the same domain, network, subnet… no VPN

Any advice is much appreciated!


I have been looking for this answer aswell but unfortunately with no luck so far. An nDisplay dev said that a they will add this feature in upcoming UE4 updates which was before 4.24.
I am not sure if they included it already in 4.25.

Did you maybe achieve it by now or got any new answers on this topic?

Answering my own question:

the missing bit was a flag that MUE needs when you run your project in ‘-game’ mode (as we do in the nDisplay launcher). To make it work, provide the following flag under ‘Custom command line arguments’ in the nDisplay launcher:


From the docs:

Were you able to edit through multi-user while nDisplay is running? and does it get updated during the nDisplay run time? we tried the same thing and we used “-messaging” code as you said, now our nDisplay is loading and the moment it gets connected to ‘Workstation 1’ and the session ‘Test’ starts then nDisplay gets crashed, but individually both nDisplay and MUE running fine.

Hi! We did get it to work and to update in both sessions. Unfortunately it’s been a while, so can’t remember if we had to do anything else. But usually the best way to debug nDisplay crashes is through the logs, which you’d find (from memory) in the ‘saved’ folder within your project. Good luck!

Exact same problem here, anything new on the subject ?

Hey guys, bumping this one up, is this something that officially works or is it still kinda in development?.. 4.25.4? … 4.26?

It worked with 4.26.
Nodes launched by the nDisplayLauncher must automatically enter the editing session.

need -messaging option