NavMeshBoundsVolume only works in editor

I have a huge problem with the NavMeshBoundsVolume. It does work when i’m starting my game in the editor, but when i try to release my game it wont work. The enemies just stand there.

I’m slowly at the point where i wanna stop using UE4, bcuz it’s pointless for me when i put so much hours into my game when i can’t even release it correctly. There is no point for me to make a game which only i could play with the editor :expressionless:

If someone still has this problem. First be sure you have your navigation view on, pressing P. Then scale up your NavMeshBoundVolume, cover up a good area from of your StaticMesh. If after that no green or red area appears, the problem is that your Static Mesh has no collision primitives. On the Static Mesh’s editor, check if you have Collision Primitives > 0. If not, you can add collision boxes on the collision menu, or redo your static mesh in your 3d modeling program and add it there. Another option, in the case you don’t want to add collision on your static mesh, is to add BlockVolumes boxes on your level, scale it properly and make sure it’s within the high level of your NavMeshBoundVolume, that should do the job!!

I had this same issue with some drones I had added to a level. They worked fine in editor but not in package. After some trial and error and getting the NavMeshBoundsVolume to the best settings I could.

I found that by simply moving the drone blueprint just above the green landscape navigation layer and so that no part of it touched the green layer - it then worked!