Download

Navmesh not working properly!

I am having a problem with the navmesh not loading correctly on a certain stairway. I have multiple stairways in my level and I set all of their navmeshes up the same way, however one of my stairways have a cut in the navmesh on one of the stairs causing my AI to not be able to walk through it. You can see the cut in the first two screen shots below.


I have attached another screen shot of another one of my stairways with the same spot of navmesh working.

I have tried deleting the navmesh and re-applying it. I have tried deleting the static mesh stairway and putting it back. I’ve tried splitting the navmesh into different sections on the stairway, however, every time I cover the entire stairway with navmesh, that small part gets cut again.

I have noticed however that moving the stairway and navmesh does fix it, but the stairway must be in that exact location and moving my entire level would be a pain.

Any ideas or help on how to fix this would be greatly appreciated! If more clarification on the situation is needed feel free to ask please!

I usually fix this by adjusting the settings in the Recast NavMesh actor. I think you have to decrease the cell size or something like that.