Download

Navmesh Not Generating Correctly

Hey,

So after I moved stuff around in my level the navmesh is incorrectly offset. I have looked online for solutions but its always one guy replying “Delete it and rebuild” and then the author says that it fixed the problem.

The problem is that I tried that and it didn’t fix it. I deleted the navmesh → rebuilt everything and saved → placed a new navmesh → rebuilt everything again and saved, still it just won’t move and it stays in the exact incorrect spot every time. I know it’s a bug. I would appreciate help on this a lot, thanks :slight_smile:

Picture of the navmesh being in the incorrect location:

Have you played with these:

Hard to tell what’s going on from that angle. Try adjusting Cell Height one way or another.

1 Like

Hey @Everynone,

I believe the issue is not with the generation settings but with the navmesh generation itself being bugged. In the picture I have you can see that the empty part of the navmesh, which is supposed to be around the wall, is instead in front of it and the green part has been generated inside the wall. This is obviously not supposed to be like this no matter what the settings are. There is also that weird tear in the navmesh on the right for some reason.

Oh!

I actually scrolled through the whole list of actors on the level and I noticed that there is a second navmesh in the level which has the same name as yours. I deleted that one as well and rebuilt it, and it seems to have fixed it.

Thank you :slight_smile:

1 Like