Nav Mesh Issues?

I see a similar question to this recently but…why is my nav mesh not adding green or red areas to the first person BP template example map?? I’ve been running some animating tests and I can’t get any of the skeletal meshes to move…any idea anyone???

If it isn’t showing up as you create a Nav Mesh press P or enable Show > Navigation.

thank you!!

Jacky was correct. pressing P resolved the issue.

I have also this problem and now it’s solved, Thank you :slight_smile:

Hi, the OTHER answer that had me stumped is that the NavMesh won’t update until you get out of Geometry Editing mode!

After I changed a NavMesh, pressing P wouldn’t do anything. Even trying to explicitly rebuild the NavMesh using Build didn’t help. My character could not move around.

What fixed it was going into the Volumes editor and then pressing P and doing a build.

Same issue. Shocked pressing ‘P’ could sort it out. What a strange engine!

In my case I couldn’t see the NavMeshBox because its green-red zone was under the landscape. Try to scale and move NavMeshBox around your scene. But don’t hurry to much after every replacing it need sime time to compile and get visible in viewport.