Nav mesh inside mesh

After migrate my project from 4.12 to 4.13 i can’t build nav mesh inside the mesh.
So, I tried make it in first shooter template. But i cant do it

Can any body halp me?

So, in 4.12 it worked very well

Hey UaLightning12,

I have a few questions:

  • Is the mesh that you can’t get the Nav Mesh to generated in a BSP brush, or is it something you’ve imported from a modeling program?
  • Does the mesh you’re trying to build the Nav Mesh on have collision enabled on it?
  • Would you be able to provide the affected mesh so I can try it on my end?

Hi, Sean Flint!
I can’t get the Nav Mesh to generate something I imported from a modeling program.
Yes, collision is enabled.
You can create something like cave from BSP and convert to static mesh.
So, its work very good in 4.12.
Thanks you!

I’ve attempted to reproduce this issue in a clean project. Here’s what I did:

  1. Created a hollow bsp brush
  2. Created a subtractive bsp brush to make a doorway in the hollow brush
  3. Converted both brushes into a static mesh
  4. Placed a Nav Mesh Bounds Volume.

After doing this, my nav mesh generated just fine as seen in the image below.

Are you able to reproduce this consistently in a clean project? If so, please provide a detailed list of steps. Thanks!

Hi, Sean Flint!

  1. I create 1st person template
  2. Created from BSP something like tunnel or cave

  1. Convert to static mesh
  2. Build navigation

So, you can also create an empty project and try build navigation inside the cave ([FREE] Luos's FREE Modular Caves/Rocks mini Package! - Community Content, Tools and Tutorials - Unreal Engine Forums

I have been able to reproduce your issue and have entered a report, which you can track here: Unreal Engine Issues and Bug Tracker (UE-37221)

Thank you for your report.

Have a great day

Issue still exists in 4.20. Ridiculous, it makes navmesh almost redundant unless you’re willing to manually assign modifiers.