Download

Nav Mesh does not include Skeletal mesh

I have a nav mesh placed. And I have my skeletal mesh on the surface.
When I press P I can see the green area which tells me the nav mesh area:

As you can see on the picture. the little guy over ther is a skelatal mesh. the and cube on his side is a static mesh.
The nav mesh system “sees” only the static mesh and not the skelatel mesh.
Why? how can I get the nave mesh system see the skelatal mesh too?

UP…

Hi Darkstorm1997,

Skeletal Meshes do no affect Nav Meshes. If you need other AI to navigate around your Skeletal Mesh try using DetourCrowds Blueprint class instead of AI Controller BP class.

This will allow other AI to navigate around each other.

Hey Tim. First of all I am working with C++ and not blueprints.
I have look for DetourCrowds and I have found that for enabling it I need to do this:


 AMyVeryOwnAIController::AMyVeryOwnAIController(const FPostConstructInitializeProperties& PCIP)
 : Super(PCIP.SetDefaultSubobjectClass<UCrowdFollowingComponent>(TEXT("PathFollowingComponent")))
 {
     // ...
 }

https://answers.unrealengine.com/questions/73218/how-to-enable-detour-crowds-in-ue43.html
But this is a solution for UE 4.3 and not UE 4.7.
How can I enable Detour Crowds in the latest version (4.7.5)?

UP…