Download

Mydemolevelproject troubles

Hey all,

New to posting on the forum but I’m at a point where I’d really appreciate some help(I tried looking things up but couldn’t find it).
I’ve been following the Unreal Engine Youtube tutorials and everything went fine until I’m trying to continue the project today.
When in the viewport, the office looks fine from the outside. But as soon as I try and launch it some weird blocks show up on the outside which I seriously can’t find in the editor. It wasn’t like that the last time before I quit the editor so it’s weird that it’s suddenly there.
Also, I know that you have to press build to build lighting etc, but for some reason that doesn’t work anymore and the message still pops up in the launch version.
See screenshots below to see what I mean:


One last question:

Since the mydemolevelproject relies on the backbone of the firstpersonshooter template, it also shows the firstpersonshooter game when I try and package the game as a .exe.
How do I make it so that the demolevelproject runs instead of the firstpersonshooter level?

Thanks for the patience for my noobness =]

I believe it are three crossbeams sticking out since they’re in the exact same place as the crossbeams inside. Though they don’t stick out in the viewport so I don’t get why they do show up when I “launch” the game instead of “play” inside the viewport.
Still didn’t find a solution as to why my lighting won’t rebuild, the message is always there when launching and clicking Build doesn’t making the message go away even though the lighting has been built after. Copied the project to a friends PC and same problems over there.

Ok so I saved the level with a different name and that fixed it. No clue what the cause of the problems was but yea no lighting message anymore and the blocks are gone so hurray!

Interesting, ue4 keeps you surprised when looking at it’s bugs, errors and ghosts.

I had this same issue! Changed the name and bam, worked! Glad you got it figured out!

so weird right!?

do you guys by any chance have an idea how to make sure the “Mydemolevelproject” level starts when you package it to a .exe for shipping? instead of the first person shooter template?

Edit>Project settings> Game Default Map.

Good luck with your project :smiley:

awesome, thanks a lot! let’s continue this tutorial thing for now haha, stuff is starting to make sense ^^