My UE 5 dont have Quixel bridge integrate

Hey guys, im a starter in UE 5 and im watching some tutorials, some of the Epic Team and others from Youtubers, but in all tutorials they teach how to use the Quixel Bridge inside the UE 5, but my engine dont have this feature. :frowning:
In my research i see this is a integrate feature and i dont undertund how mine dont have Quixel Bridge.

Can anyone help me? Or anyone with the same problem?
Images below:

i’ll let you know if i get this solved because i’m going through it myself.
everything with quixel bridge worked in 4.26, i installed 5 (release not EA, never installed EA), and now here we are, unable to quixel!

There was an issue with new installations/new users not being granted the correct entitlement for Quixel Bridge to show up that has now been resolved. However, for those still affected, we ask you to make sure you restart your launcher (make sure everything UE is closed), and then search your vault for Quixel Bridge and install to Engine from there.

Let me know if this works for you!

Hi SkyeEden, this does not work for me. I’ve restarted launcher, logged in and out as well.

Message you :slight_smile:

1- uninstall all previous engines - including 4.27 . 4.26 –
2- uninstall UE5
3- Uninstall epic games launcher…

  • feeling empty? no worries:)
    now install new version of epic games installer 13.3.0
    and then install UE5
    you will see all your bridge features including quixel.

I was trying everything for many many hours - so that worked for me… finally:)

Hey guys, i reinstall UE5 and its working now, thanks all!! :slight_smile: