Download

My stacking mod and raw mutton issue

Hello again,

another problem with stack raw mutton.

When I cook is the result 70% prime meat and 30% lamb chop.
I can not explain this…

Why I do not get 100% of lamb chop?

Someone an idea?

-Holgi

nobody an idea?

I ran into a similar issue as Fish Meat was introduced. I never was able to find a solution so far.
The cause of this seems to be the fact, that the Devs decided not to make a complete new PrimalItemConsumable. All the new meats are already childs of the normal meat. And for a stack mod you have to create your own child, which is then “the child of the child of raw meat”. And this seems to completely confuse the cookers.

You could try to play around with the option "“Override Exact Class Crafting Requirement”.

If this doesn’t help you need to go a unclean way, like many other mods do. They also mod the crafting/cooking stations to make their items work correctly.

Override Exact Class Crafting Requirement cooks the parent meat as well. This will cause raw mutton to turn into BOTH cooked prime and lamb chops. Any differences in how much is produced likely comes from the difference in cooking time.

So if I get you right, you are saying disabling this option should do the trick? Last time I tried, this also wasn’t the solution I was looking for. But maybe it works with this newer DevKit Versions.

Maybe it’s because I was toying with things for my stack mod, but my grill cooks PrimeMeatFish_Child and LambChop_Child with RawMutton_Child without any issues. That option is disabled. With it enabled, it’ll override the requirements for PrimeMeat and cook PrimeMeat(_Child?) every x second, and LambChop_Child every y seconds.

I checked this again. Disabling “Override Exact Class Crafting Requirement” for Fish or Mutton Meats results in nothing gets cooked at all.
Enabling it for Fish Meats results in 50% Cooked Meat and 50% Cooked Fish Meat.
Enabling it for Mutton results in 100% Cooked Prime Meat. Possibly because crafting time for Cooked Prime Meat is just way faster…

So I can’t imagine how you did this other than also modifying the Cookers.

EDIT:
Got it! At least if you can live with modding the cooked meats also. If not you are still screwed.

  1. Remove all “Override Exact Class Crafting Requirement” from your Childs
  2. Inside the Cooked Meats, e.g. “PrimalItemConsumable_CookedMeat_Fish_MyChild”, search for “Base Crafting Resource Requirements” and Change “PrimalItemConsumable_RawMeat_Fish” to “PrimalItemConsumable_RawMeat_Fish_MyChild”

Yes that’s it, thank to all:cool:

That’s an oversight on my part, I figured the cooked meats were already modified to require the modded raw stacks :slight_smile:

And also, the obscured results are from crafting times. If you take PrimeMeat_Child and LambChop_Child and add them to a grill then set their crafting to 1s, a RawMutton_Child will be used to craft both with “Override Crafting Requirements” enabled. Lovely world of subclasses we have here.

So True…

BTW, Just an Addition to my Solution above:
If you don’t have modified Jerky Meats, you will need to add “Override Exact Class Crafting Requirement” to Cooked Meat and Cooked Prime Meat. If not there will be no Jerky anymore.