My sprint layout makes me sprint on start. why?

So I am making a new map and I add the basic sprint layout as shown in the image below and now whenever I start I always start out going the sprint speed. Once I am moving and I press shift which is supposed to make me spring nothing happens, but when I let go then I go to walk speed. If that did not make sense this is a summary: Sprint layout makes me sprint at start instead of walking and sprint button makes me walk normally.

The issue seems to be that the layout is working when i preview it as I run the game, but it is not registered until I hit the sprint button the first time. So until I hit shift I am sprinting and after that it works.

on event begin play set the max walk speed to 400

Exactly. I did this on 2 other projects and it works fine, but not this one.

Check the default “walk speed”…could be starting at 700

1 Like

Didn’t work… Thanks though

Is that Max Walk speed connected to anything else?

Had the same issue, i used “is sprint pressed” as a variable and it was marked as “true” in the setting by default. changing it to “false” worked, i no longer sprinted on start up. hope this helps.

You posted this over three years after he asked the question, now - 1.5 years later you saved my a s s from flipping! Thank you <3