My RTX Dev Kit experience

I have been working on a map in the Ark Dev Kit for the past 14 months. I had a computer with the following specs.:

Gigabyte X399 Gaming 7
AMD Threadripper 1950X
Corsair Dominator DDR4 64 GB
EVGA GTX 1080 Ti
Samsung EVO 830 1 TB SSD (where the Dev Kit is installed)
Samsung EVO 960 Pro (Windows 10 Pro build 1803)

Everything was running well. Only the occasional Dev Kit crash.

One day the GTX 1080 decided not to bring up my primary display. No driver or Windows updates. Un-installed and re-installed drivers. Booted off of a Linux USB Live drive. Nothing. It was dead. Nvidia stopped making the 1080 Ti and the 1080 when the 2080 was released in September 2018 so an RTX 2080 was my best option, or so I though.

I replaced the video card and got my drivers updated and everything looked great. I fired up Ark and it immediately crashed. Validated files. Crashed again. Started the Dev Kit and everything looked good. I opened my project persistent level with no issues. Looking good so far except Ark is busted. I loaded my landscape level and the Dev Kit crashed. This repeated several more times with many different settings being tried with the same results. The only error was “D3D device lost”. Most of the time it gave me no errors at all.

So I opened a ticket with Nvidia Support. I sent them my error logs. They had my try a few different drivers and record the results for them. This testing included 18 GB of error logs that I recorded and sent to Nvidia and it lasted until Dec 2018. Nvidia was more than happy Ark is mostly working now but gave up on the Dev kit issue I am having and closed the ticket.

It has now been almost 10 months since I have been able to load the landscape on any map in the Ark Dev kit without crashing it.

In the past 10 months I have reinstalled the following items;

Windows: 13 times
Video Drives: 30+ times
Ark Dev Kit: 25+ times

I have also;
Replaced the RTX video card 3 times.
Replaced the CPU 2 times.
Replaced the PSU 1 time.
Replaced the RAM 2 times.
Underclocked the CPU and GPU.
Overclocked the CPU and GPU.
Replaced the motherboard.
Removed and reinstalled all USB drivers 25+ times.
Installed the Dev Kit to a different drive to eliminate that possibility.
Removed all but 1 monitor from the video card.
Rebuilt the main computer.

On the map:
Removed shadows from ground clutter.
Tried multiple different landscape materials. They all crash even with no ground clutter.

Current computer:

Gigabyte X399 Auros Gaming 7
AMD Threadripper 2950X
Corsair Dominator DDR4 64 GB
Samsung EVO 840 2 TB SSD (where the Dev Kit is installed)
Samsung EVO 960 Pro (Windows 10 Pro build 1903)

Now the Dev Kit doesn’t even give me an error when it crashes. It just stops responding moments after loading the landscape. I am at a total loss what to do. I am seriously considering removing my map from the workshop because I can’t do anything to make progress and haven’t for several months. This is flushing over 2000 hours of time and work down the drain because Nvidia and Unreal don’t want to play nice.

I don’t know what to do.

Did you try increasing TDR Values ?

if above doesnt work and you can load vanilla maps fine then i am guessing during devkit crashing on you, some of your map files got corrupted if they were open, maybe look into that. Good luck.

I know a little late, but this error is know and solved, set your heightfild shadows to low and or work perfect, in ark self set terrain shadows to low and ark runs without crash, this is only to rtx cards, hope I can help you and recommend to join the ark modding discord server,
Peace out :slight_smile: