Download

My project or even single blueprint wont open in any other engine version????

OMGGGG, I really need help, I have been developing my game on a github version o ue4 4.12 for the past year, so i recently decided to upgrade to 4.14 but it wont work, the engine just crashed when trying to open up the project, so i donwloaded 4.13 and same thing, i also tried on 4.12 and same thing, then i tried 4.13 on the launcher and SAME THING, and im not talking about the whole project i mean anything created inside my github version of 4.13 wont work on any other version of the engine, even a brand new blueprint created in github 4.13 will just crash trying to open in any other version, i have a feeling it has something to do with me changing engine version a couple of months ago by changing the objectverion.cpp file to get a map to load so now nothing works on other engine :frowning: i really need help, someone please I am the creator of dragonball unreal so i really need to be able to continue development, 50$ to the first person to solve my problem

If you changed engine source code, it will think you’re on a custom engine version.

BTW you should have attempted to upgrade a copy of the project, not the original.

You could always start a new 4.14 fresh project, and then just migrate over the assets you want from your project on a case by case basis. (assuming you can still open you project from a SCM backup)

i cant thats the thing, i cant even take a single blueprint from my project and open up in any other version of the engine besides the custom 4.13 i am running now, if i run in any other version it crashes.

the project still works fine on the custom 4.13 engine just not on any other, i have tried ever version from the moon and back and the only verison that runs is the custom version i have :frowning: i cant even open a single blueprint in any other version

Pleaseeeeee will pay 100usd to whom ever has a fix, any file i create in 4.13 custom engine can only work in that engine it cannot work in any other version arhhhhhh but i need my project to run on 4.14

Does it work in standard 4.12?

So what happens when you:

  1. Launch Stock 4.14, create new project and save it.

  2. Launch your project in custom engine.

  3. Select a blueprint in your project, right-click, migrate, choose content folder of new project.

  4. open blueprint in new project. Are there compile errors? Paste them here

nope :confused: but i found if i add 2 lines to the objectversion.h in 4.12 then it would open but not on anyversion higher then 4.14

okay just tried and its weird because in the custom engine when i got to migrate, in the migration menu i cant see some of the blueprints and mesh’s ect

bumpppppppppppppppppppppp