Download

My project is broken two year of work, please help.

Add New–>Feature or Content Pack–>(C++ tab) First Person. Closed the project and after i tried to fire up the project i got the message:

the following modules are missing or built with a different engine version:

Project name

Would you like to rebuild them now? y/n

and then almost instantly i get the message:

ProjectName could not be compiled. Try rebuilding from source manually.

Im no programmer, don’t even have c++ setup on pc. I tried doing a test bug on fresh project and same thing happened.

Thank you.

If you don’t have a C++ setup or Visual Studio installed, then you can’t use C++ code. You need to go into the project directory and delete the ‘Source’ and ‘Intermediatte’ folders, as well as any of the content the feature pack added.

You may also need to edit the .uproject file in notepad, and remove the “modules” section if it’s there.

Also you should ***really ***look into source control. It’s only a matter of time before you lose all that work otherwise.

I did the things you recommended however when i delete the module part inside the notepad the project can not be launched. If it’s not too big of a trouble u can add me on discord so i can share screen Dre#6400 There are a lot of save / backup logs in the project forlders, can’t i just somehow launch precious saves of the project?

Thank you

If what you selected on your picture is what you’re deleting, then that’s probably why you can’t launch it after that. you have to delete everything about modules, not only what’s inside.
To see what you need to delete, you can just create a new empty blueprint project and take a look at the .uproject file from that one to see its structure.