My project does not open

When I open my project it gives the following error:

[2017.07.28-20.47.28:509][ 0]LogProperty:Error: UStructProperty::Serialize Loading: Property ‘StructProperty /Game/Blueprints/Player.Player_C:powerPlant’. Unknown structure.

[2017.07.28-20.47.28:509][ 0]LogClass:Warning: Property powerPlant of powerPlant has a struct type mismatch (tag STRUCT_REINST_powerPlants_0 != prop FallbackStruct) in package: …/…/…/…/…/…/Users/xxxx/xxxx/xxxx/xxxxxx/Content/Blueprints/Player.uasset. If that struct got renamed, add an entry to ActiveStructRedirects.

[2017.07.28-20.47.28:515][ 0]LogClass:Warning: Property powerPlant of powerPlant has a struct type mismatch (tag FallbackStruct != prop powerPlants) in package: FObjectReader. If that struct got renamed, add an entry to ActiveStructRedirects.

[2017.07.28-20.47.28:604][ 0]LogLinker:Error: Bad name index -858993349/40

[2017.07.28-20.47.28:604][ 0]LogLinker:Error: Bad name index 6463/40

[2017.07.28-20.47.28:606][ 0]LogWindows: Windows GetLastError: The operation completed successfully. (0)

It’s not clear. Try to delete or move Player.asset outside the o folder and restart the prpject. Maybe it’ll tell you you missed an asset, but it may open fine
If this isn’t the issue, try loolng for the error codes it returns you

I removed all .uassets from the blueprints folder and my project opened. However when I go to fix the compilation errors the same error happens:

[2017.07.31-11.48.50: 831] [653] LogLinker: Error: Bad name index -858993349/40

[2017.07.31-11.48.50: 831] [653] LogLinker: Error: Bad name index 6463/40

What would be a bad name?

Look if you can find what’s at the index:

Are you developing a VR project? Or what kind of game are you developing? Have you enabled some plugin (or forgot to enable some)?

Looking around some similar issues, I’ve found out it may be that two assets are corrupted. you have to find them and delet or replace them.
As I read you former question, I think you renamed an asset, and at compiling there is a missed corrispondence between call and asset.
I’d suggest you to create those blueprint again.

Ok. I’ll search at my project.

Let me know if you find something

How to search for these indexes ( -858993349/40 6463/40)? My project is a little big.

in output log there is a search bar, but I don’t mnow if and how you can look for a index without compiling.
The output log you posted says you have a struct type mismach at player.powerplant
and something renamed at Player.uasset.
Do you know what are these?

powerplant is a struct. I created it to use a dataTable. This dataTable contains data used in widgets. The struct contains enumerator, float, and text fields. I believe this struct is corrupted. But even deleting it, the error continues to appear. Should I remove some file besides .uasset?
I should remove all widgets that reference this struct? Because the error happens when I open the widgets that use this struct.

I think you’ve answered yourself. Your project is surely more complicated than my archviz.
Since you have a datatable, those index will be referred to that datastruct. So if you know how to move though this datatable, great. It is a struct type mismatch, so maybe widget is trying to read a float but can’t get string (example).
You may also try to delete single widgets and see if all of them return the same error or it’s just one.
In worst case, you’ll have to recreate the powerplant.

I do not know why but the problem was solved when I removed another data table, a table that I stored the colors used in my game. I think this table was corrupted, because now the widgets are opening normally.

probably there was a wrong call and a type mismatch on there. glad you solved.

Thank you for your attention